aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-ncarray/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-ncarray/Makefile')
-rw-r--r--math/octave-forge-ncarray/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/octave-forge-ncarray/Makefile b/math/octave-forge-ncarray/Makefile
new file mode 100644
index 000000000000..e8d7f28ed307
--- /dev/null
+++ b/math/octave-forge-ncarray/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: octave-forge-ncarray
+# Date created: 20 July 2012
+# Whom: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-ncarray
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ncArray
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/octcdf.tar.gz:${PORTSDIR}/math/octave-forge-octcdf
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.post.mk>