aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-ponchon-savarit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-ponchon-savarit/Makefile')
-rw-r--r--math/octave-forge-ponchon-savarit/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/math/octave-forge-ponchon-savarit/Makefile b/math/octave-forge-ponchon-savarit/Makefile
index 8ba9799cb2b5..ad6bf20ff898 100644
--- a/math/octave-forge-ponchon-savarit/Makefile
+++ b/math/octave-forge-ponchon-savarit/Makefile
@@ -8,27 +8,16 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
WWW= https://packages.octave.org/
LICENSE= GPLv3
-LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTAVE_SRC}/COPYING
+USES= octave
USE_GITHUB= yes
GH_ACCOUNT= aumpierre-unb
GH_PROJECT= Ponchon-Savarit-for-GNU-Octave
-# OCTSRC is the name of the directory of the package.
-# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${GH_PROJECT}-${DISTVERSION}
-
-WRKSRC= ${WRKDIR}/${OCTSRC}/src
-
-do-build:
- @${DO_NADA}
+OCTAVE_SRC= ${GH_PROJECT}-${DISTVERSION}
NO_ARCH= yes
-
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
-
-post-build:
- ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+NO_BUILD= yes
.include <bsd.port.mk>