aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-sockets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-sockets/Makefile')
-rw-r--r--math/octave-forge-sockets/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/octave-forge-sockets/Makefile b/math/octave-forge-sockets/Makefile
index ade066c46ef2..08bff6e19c9a 100644
--- a/math/octave-forge-sockets/Makefile
+++ b/math/octave-forge-sockets/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= octave-forge-sockets
-PORTVERSION= 1.0.7
-PORTREVISION= 4
+PORTVERSION= 1.0.8
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
@@ -15,12 +14,17 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${DISTNAME}
+OCTSRC= ${OCTAVE_PKGNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
+BUILD_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-patch:
+ ${REINPLACE_CMD} 's/sed/gsed/g' ${WRKSRC}/Makefile
+
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}