aboutsummaryrefslogtreecommitdiff
path: root/math/plplot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/plplot/Makefile')
-rw-r--r--math/plplot/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 910116271d60..92951713bd9b 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -74,14 +74,13 @@ GD_USES= jpeg
GD_CMAKE_BOOL= PLD_png
LUA_USES= lua
-LUA_BUILD_DEPENDS= swig3.0:devel/swig30
+LUA_BUILD_DEPENDS= swig:devel/swig
LUA_CMAKE_BOOL= ENABLE_lua
LUA_CMAKE_ON= -DLUA_EXECUTABLE:FILEPATH="${LUA_CMD}"
PYTHON_USES= python:2.7
-PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30 \
+PYTHON_BUILD_DEPENDS= swig:devel/swig \
${PYNUMPY}
-PYTHON_BINARY_ALIAS= swig=swig3.0
PYTHON_RUN_DEPENDS= ${PYNUMPY}
PYTHON_CMAKE_BOOL= ENABLE_python
PYTHON_CONFIGURE_ENV= PYTHON_VERSION="${PYTHON_VERSION}"