aboutsummaryrefslogtreecommitdiff
path: root/math/py-gimmik/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-gimmik/Makefile')
-rw-r--r--math/py-gimmik/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/py-gimmik/Makefile b/math/py-gimmik/Makefile
new file mode 100644
index 000000000000..9c675fdf3b32
--- /dev/null
+++ b/math/py-gimmik/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= gimmik
+DISTVERSION= 2.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Generator of Matrix Multiplication Kernels
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}
+
+USES= python:3.3+
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>