aboutsummaryrefslogtreecommitdiff
path: root/math/py-pygsl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-pygsl/Makefile')
-rw-r--r--math/py-pygsl/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/math/py-pygsl/Makefile b/math/py-pygsl/Makefile
index 4afa0ab1a7e3..a012404752d3 100644
--- a/math/py-pygsl/Makefile
+++ b/math/py-pygsl/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pygsl
-PORTVERSION= 2.3.2
+PORTVERSION= 2.3.3
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +11,14 @@ WWW= https://github.com/pygsl/pygsl
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libgsl.so:math/gsl
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +