aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-image/Makefile19
-rw-r--r--math/octave-forge-image/distinfo3
-rw-r--r--math/octave-forge-image/pkg-descr15
-rw-r--r--math/octave-forge-image/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8d4519227899..ea8bf5956ff3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -191,6 +191,7 @@
SUBDIR += octave-forge-engine
SUBDIR += octave-forge-fpl
SUBDIR += octave-forge-gsl
+ SUBDIR += octave-forge-image
SUBDIR += octave-forge-informationtheory
SUBDIR += octave-forge-integration
SUBDIR += octave-forge-io
diff --git a/math/octave-forge-image/Makefile b/math/octave-forge-image/Makefile
new file mode 100644
index 000000000000..10162414c42c
--- /dev/null
+++ b/math/octave-forge-image/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: octave-forge
+# Date created: 5 May 2004
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-image
+PORTVERSION= 1.0.8
+CATEGORIES= math
+
+MAINTAINER= stephen@math.missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LIB_DEPENDS+= MagickCore:${PORTSDIR}/graphics/ImageMagick
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-image/distinfo b/math/octave-forge-image/distinfo
new file mode 100644
index 000000000000..a182f412ffcd
--- /dev/null
+++ b/math/octave-forge-image/distinfo
@@ -0,0 +1,3 @@
+MD5 (octave-forge/image-1.0.8.tar.gz) = 36f1c7fe346752b5bcca1725eff56072
+SHA256 (octave-forge/image-1.0.8.tar.gz) = 141de14d3ac97e0acefbaa718a4d402d826ab920fe2fd3b9bd42285760fd6c6f
+SIZE (octave-forge/image-1.0.8.tar.gz) = 205608
diff --git a/math/octave-forge-image/pkg-descr b/math/octave-forge-image/pkg-descr
new file mode 100644
index 000000000000..dfcee5184cc8
--- /dev/null
+++ b/math/octave-forge-image/pkg-descr
@@ -0,0 +1,15 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is image.
+
+ The Octave-forge Image package provides functions for
+ reading, writing, and processing images. The package supports
+ almost all image formats through the use of ImageMagick.
+ The package also provides functions for feature extraction, image
+ statistics, spatial and geometric transformations, morphological
+ operations, linear filtering, and much more.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-image/pkg-plist b/math/octave-forge-image/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-image/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty