aboutsummaryrefslogtreecommitdiff
path: root/misc/buffer
diff options
context:
space:
mode:
Diffstat (limited to 'misc/buffer')
-rw-r--r--misc/buffer/Makefile18
-rw-r--r--misc/buffer/distinfo1
-rw-r--r--misc/buffer/pkg-comment1
-rw-r--r--misc/buffer/pkg-descr10
-rw-r--r--misc/buffer/pkg-plist1
5 files changed, 31 insertions, 0 deletions
diff --git a/misc/buffer/Makefile b/misc/buffer/Makefile
new file mode 100644
index 000000000000..d13269b687f0
--- /dev/null
+++ b/misc/buffer/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: buffer
+# Version required: 1.17
+# Date created: 23 February 1998
+# Whom: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
+#
+# $Id$
+#
+
+DISTNAME= buffer-1.17
+CATEGORIES= misc
+MASTER_SITES= http://www.freebsd.org/~steve/
+
+MAINTAINER= jonny@jonny.eng.br
+
+NO_WRKSUBDIR= yes
+MAN1= buffer.1
+
+.include <bsd.port.mk>
diff --git a/misc/buffer/distinfo b/misc/buffer/distinfo
new file mode 100644
index 000000000000..7fc3aa45b303
--- /dev/null
+++ b/misc/buffer/distinfo
@@ -0,0 +1 @@
+MD5 (buffer-1.17.tar.gz) = 6c5236ed99f4df0832623f4c0498c681
diff --git a/misc/buffer/pkg-comment b/misc/buffer/pkg-comment
new file mode 100644
index 000000000000..6b5d448dfefe
--- /dev/null
+++ b/misc/buffer/pkg-comment
@@ -0,0 +1 @@
+Buffer sporadic I/O for faster tape and pipe throughput.
diff --git a/misc/buffer/pkg-descr b/misc/buffer/pkg-descr
new file mode 100644
index 000000000000..384bde054f83
--- /dev/null
+++ b/misc/buffer/pkg-descr
@@ -0,0 +1,10 @@
+This is a program designed initially to speed up writing tapes on remote
+tape drives, but may be used as a general pipe buffering utility.
+Note: You must have SYSVSHM support in FreeBSD kernel.
+
+The program splits itself into two processes. The first process reads
+(and reblocks) from stdin into a shared memory buffer. The second
+writes from the shared memory buffer to stdout. Doing it this way
+means that the writing side effectly sits in a tight write loop and
+doesn't have to wait for input. Similarly for the input side. It is
+this waiting that slows down other reblocking processes, like dd.
diff --git a/misc/buffer/pkg-plist b/misc/buffer/pkg-plist
new file mode 100644
index 000000000000..e8128197197f
--- /dev/null
+++ b/misc/buffer/pkg-plist
@@ -0,0 +1 @@
+bin/buffer