aboutsummaryrefslogtreecommitdiff
path: root/misc/countrycodes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/countrycodes/Makefile')
-rw-r--r--misc/countrycodes/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/misc/countrycodes/Makefile b/misc/countrycodes/Makefile
index 9f07cf3c38e7..8fc28ee14493 100644
--- a/misc/countrycodes/Makefile
+++ b/misc/countrycodes/Makefile
@@ -15,21 +15,19 @@ LICENSE= GPLv2
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-PLIST_FILES= bin/iso3166
+PLIST_FILES= bin/iso3166 man/man1/iso3166.1.gz
PORTDOCS= README
-MAN1= iso3166.1
-MAKE_ARGS= prefix="${PREFIX}" CC="${CC}" CCOPTS="${CFLAGS}" WARNINGS=""
+MAKE_ARGS= prefix="${STAGEDIR}${PREFIX}" CC="${CC}" CCOPTS="${CFLAGS}" WARNINGS=""
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>