aboutsummaryrefslogtreecommitdiff
path: root/misc/gonvert/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gonvert/Makefile')
-rw-r--r--misc/gonvert/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/misc/gonvert/Makefile b/misc/gonvert/Makefile
index 71ea3efa2542..2da7a82b8a9c 100644
--- a/misc/gonvert/Makefile
+++ b/misc/gonvert/Makefile
@@ -7,31 +7,34 @@
#
PORTNAME= gonvert
-PORTVERSION= 0.2.01
+PORTVERSION= 0.2.05
CATEGORIES= misc python gnome
MASTER_SITES= http://www.unihedron.com/projects/gonvert/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= A conversion utility that allows conversion between many units
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
-
USE_X_PREFIX= yes
-USE_GNOME= gnomehier
+USE_GNOME= gnomehier pygtk2
USE_PYTHON= yes
-USE_GMAKE= yes
+USE_REINPLACE= yes
NO_BUILD= yes
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|#!/usr/bin/python|#!/usr/bin/env python|g' ${WRKSRC}/gonvert
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/gonvert ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/gonvert.desktop \
- ${PREFIX}/share/gnome/apps/Utilities
- ${INSTALL_DATA} ${WRKSRC}/pixmaps/gonvert_icon.png \
+ ${PREFIX}/share/gnome/applications
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/gonvert.png \
${PREFIX}/share/gnome/pixmaps
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/gonvert.glade ${DATADIR}
@${MKDIR} ${DATADIR}/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/pixmaps/*.png ${DATADIR}/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/gonvert_picture.png \
+ ${DATADIR}/pixmaps
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in README CHANGELOG FAQ README THANKS TODO