aboutsummaryrefslogtreecommitdiff
path: root/misc/nn-insight/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/nn-insight/Makefile')
-rw-r--r--misc/nn-insight/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/misc/nn-insight/Makefile b/misc/nn-insight/Makefile
index 8a3ab5758084..1b975b34e2c6 100644
--- a/misc/nn-insight/Makefile
+++ b/misc/nn-insight/Makefile
@@ -1,6 +1,5 @@
PORTNAME= nn-insight
-DISTVERSION= 1.0.5
-PORTREVISION= 2
+DISTVERSION= 1.0.7
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
@@ -10,12 +9,14 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= avir>0:graphics/avir \
- flatc:devel/flatbuffers205 \
+ ${LOCALBASE}/include/exprtk.hpp:math/exprtk \
+ flatc:devel/flatbuffers \
half>0:math/half \
nlohmann-json>0:devel/nlohmann-json \
png++>0:graphics/png++
LIB_DEPENDS= libcgraph.so:graphics/graphviz \
libpng.so:graphics/png \
+ libQCustomPlot-qt5.so:graphics/qcustomplot-qt5 \
libtcmalloc.so:devel/google-perftools
USES= compiler:c++17-lang cmake pkgconfig qt:5