aboutsummaryrefslogtreecommitdiff
path: root/misc/py-socli
diff options
context:
space:
mode:
Diffstat (limited to 'misc/py-socli')
-rw-r--r--misc/py-socli/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/misc/py-socli/Makefile b/misc/py-socli/Makefile
index f6f0335e3a63..9fbcfa9fdeaf 100644
--- a/misc/py-socli/Makefile
+++ b/misc/py-socli/Makefile
@@ -12,7 +12,7 @@ COMMENT= Stack overflow command line interface
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup4>=0:textproc/py-beautifulsoup4 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests
USES= python:3
@@ -23,4 +23,10 @@ GH_ACCOUNT= gautamkrishnar
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
+.include <bsd.port.post.mk>