aboutsummaryrefslogtreecommitdiff
path: root/misc/py-torchvision/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/py-torchvision/Makefile')
-rw-r--r--misc/py-torchvision/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/misc/py-torchvision/Makefile b/misc/py-torchvision/Makefile
index 4079d31d9a79..c17f1b5839a1 100644
--- a/misc/py-torchvision/Makefile
+++ b/misc/py-torchvision/Makefile
@@ -1,6 +1,6 @@
PORTNAME= torchvision
DISTVERSIONPREFIX= v
-DISTVERSION= 0.17.0
+DISTVERSION= 0.17.1
CATEGORIES= misc # machine-learning
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,14 +13,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpng16.so:graphics/png
PY_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=5.3.0:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytorch>0:misc/py-pytorch@${PY_FLAVOR}
+PY_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=5.3.0:graphics/py-pillow@${PY_FLAVOR} # image backend
BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
USES= python
-USE_PYTHON= distutils autoplist pytest # tests run in a very high memory
+USE_PYTHON= distutils autoplist pytest # tests run in a very high memory ; in 0.17.1 tests fail to run, see https://github.com/pytorch/vision/issues/8278
USE_GITHUB= yes
GH_ACCOUNT= pytorch