aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/diary-hercules/Makefile5
-rw-r--r--misc/documancer/Makefile6
2 files changed, 6 insertions, 5 deletions
diff --git a/misc/diary-hercules/Makefile b/misc/diary-hercules/Makefile
index 3ae79cd101d9..437597e0bea2 100644
--- a/misc/diary-hercules/Makefile
+++ b/misc/diary-hercules/Makefile
@@ -14,11 +14,12 @@ PKGNAMEPREFIX= diary-
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= A personal workout diary program for bodybuilders
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/wx-2.6-gtk2-unicode/wx/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython26-unicode \
- ${PYTHON_SITELIBDIR}/sqlite/__init__.py:${PORTSDIR}/databases/py-PySQLite11
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/sqlite/__init__.py:${PORTSDIR}/databases/py-PySQLite11
USE_GETTEXT= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+USE_WX= 2.6
+WX_COMPS= python
.include <bsd.port.mk>
diff --git a/misc/documancer/Makefile b/misc/documancer/Makefile
index 1c22a0c70d6f..a0c6d393f3b1 100644
--- a/misc/documancer/Makefile
+++ b/misc/documancer/Makefile
@@ -18,12 +18,12 @@ COMMENT= A programmer's documentation reader
BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget \
swish-e:${PORTSDIR}/www/swish-e
-LIB_DEPENDS= wxmozilla_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxmozilla
-RUN_DEPENDS= ${BUILD_DEPENDS} \
- ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython24
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= 2.4
USE_PERL5= yes
+USE_WX= 2.4
+WX_COMPS= mozilla python
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share