aboutsummaryrefslogtreecommitdiff
path: root/multimedia/arcan/files/patch-platform_cmake_CMakeLists.BSD
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/arcan/files/patch-platform_cmake_CMakeLists.BSD')
-rw-r--r--multimedia/arcan/files/patch-platform_cmake_CMakeLists.BSD15
1 files changed, 15 insertions, 0 deletions
diff --git a/multimedia/arcan/files/patch-platform_cmake_CMakeLists.BSD b/multimedia/arcan/files/patch-platform_cmake_CMakeLists.BSD
new file mode 100644
index 000000000000..af4661e3174a
--- /dev/null
+++ b/multimedia/arcan/files/patch-platform_cmake_CMakeLists.BSD
@@ -0,0 +1,15 @@
+Partially revert https://github.com/letoram/arcan/commit/3c1674a8f5db
+
+--- platform/cmake/CMakeLists.BSD.orig 2022-10-12 20:23:54 UTC
++++ platform/cmake/CMakeLists.BSD
+@@ -74,6 +74,10 @@ else()
+ set(BSD_VARIANT_DEFINITIONS
+ -DCLOCK_MONOTONIC_RAW=CLOCK_REALTIME_FAST)
+
++# FreeBSD 12.1 enabled evdev but Arcan crashes
++ if(${INPUT_PLATFORM} STREQUAL "evdev")
++ SET(INPUT_PLATFORM "syscons")
++ endif()
+ if (VIDEO_PLATFORM STREQUAL "egl-dri")
+ list(APPEND ARCAN_PLATFORM ${PLATFORM_PATH}/psep_open.c)
+ else()