aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gaupol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gaupol/Makefile')
-rw-r--r--multimedia/gaupol/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/multimedia/gaupol/Makefile b/multimedia/gaupol/Makefile
index 55646346cef8..d6f195612aca 100644
--- a/multimedia/gaupol/Makefile
+++ b/multimedia/gaupol/Makefile
@@ -1,25 +1,25 @@
-# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-
PORTNAME= gaupol
-DISTVERSION= 1.4-3
-DISTVERSIONSUFFIX= -g6116d42b
+DISTVERSION= 1.13
CATEGORIES= multimedia python
-MAINTAINER= greg@unrelenting.technology
+MAINTAINER= ports@FreeBSD.org
COMMENT= Subtitle editor
+WWW= https://otsaloma.io/gaupol/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
- ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}enchant>=1.5.1:textproc/py-enchant@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}enchant>=1.5.1:textproc/py-enchant@${PY_FLAVOR} \
+ gspell>=0:textproc/gspell \
+ iso-codes>=0:misc/iso-codes
-USES= desktop-file-utils gnome python:3.2+
+USES= desktop-file-utils gnome gstreamer: python
USE_GITHUB= yes
GH_ACCOUNT= otsaloma
-USE_GNOME= gtk30 pygobject3 intltool
-USE_PYTHON= distutils autoplist py3kplist noflavors
+USE_GNOME= gtk30 intltool pygobject3
+USE_GSTREAMER= bad good gtk libav pango ugly
+USE_PYTHON= autoplist distutils noflavors py3kplist
NO_ARCH= yes
OPTIONS_DEFINE= NLS