aboutsummaryrefslogtreecommitdiff
path: root/multimedia/snapcast/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/snapcast/Makefile')
-rw-r--r--multimedia/snapcast/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/multimedia/snapcast/Makefile b/multimedia/snapcast/Makefile
index 8b9c9c097078..1d9c36f64110 100644
--- a/multimedia/snapcast/Makefile
+++ b/multimedia/snapcast/Makefile
@@ -1,16 +1,18 @@
PORTNAME= snapcast
DISTVERSIONPREFIX= v
-DISTVERSION= 0.25.0
+DISTVERSION= 0.28.0
CATEGORIES= multimedia audio
MAINTAINER= yuri@FreeBSD.org
COMMENT= Multiroom client-server audio player
+WWW= https://github.com/badaix/snapcast
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/boost/asio.hpp:devel/boost-libs
-LIB_DEPENDS= libavahi-common.so:net/avahi-app \
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libavahi-common.so:net/avahi-app \
libexpat.so:textproc/expat2 \
libFLAC.so:audio/flac \
libogg.so:audio/libogg \
@@ -18,19 +20,24 @@ LIB_DEPENDS= libavahi-common.so:net/avahi-app \
libvorbis.so:audio/libvorbis \
libsoxr.so:audio/libsoxr
-BROKEN= error: non-constant-expression cannot be narrowed from type 'unsigned long' to 'int' in initializer list
-
-USES= cmake compiler:c++14-lang pkgconfig
+USES= cmake compiler:c++17-lang pkgconfig python shebangfix
USE_GITHUB= yes
GH_ACCOUNT= badaix
+SHEBANG_FILES= server/etc/plug-ins/meta_mpd.py server/etc/plug-ins/meta_mopidy.py \
+ server/etc/plug-ins/meta_librespot-java.py
+
OPTIONS_DEFINE= CLIENT
-OPTIONS_DEFAULT= CLIENT
+OPTIONS_DEFAULT= #CLIENT
OPTIONS_SUB= yes
CLIENT_DESC= Build and install client in addition to server
CLIENT_CMAKE_BOOL= BUILD_CLIENT
CLIENT_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+CLIENT_BROKEN= Snapclient not yet supported for FreeBSD (according to CMakeLists.txt) # see https://github.com/badaix/snapcast/issues/1098
+
+post-install: # workaround for https://github.com/badaix/snapcast/issues/1021
+ @${CHMOD} +r ${STAGEDIR}${PREFIX}/share/snapserver/plug-ins/meta_mpd.py
.include <bsd.port.mk>