aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/vdr-plugin-markad/files/patch-plugin-Makefile')
-rw-r--r--multimedia/vdr-plugin-markad/files/patch-plugin-Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile b/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
new file mode 100644
index 000000000000..15ca635394a9
--- /dev/null
+++ b/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
@@ -0,0 +1,18 @@
+--- a/plugin/Makefile
++++ b/plugin/Makefile
+@@ -100,10 +100,15 @@ i18n: $(I18Nmsgs) $(I18Npot)
+ ### Targets:
+
+ install:
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
+
+ libvdr-$(PLUGIN).so: $(OBJS)
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -o $@
++ifdef FREEBSD
++ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++else
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
++endif
+
+ clean:
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.so.* *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot