aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x265/files/patch-disable-avx-for-clang
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/x265/files/patch-disable-avx-for-clang')
-rw-r--r--multimedia/x265/files/patch-disable-avx-for-clang13
1 files changed, 13 insertions, 0 deletions
diff --git a/multimedia/x265/files/patch-disable-avx-for-clang b/multimedia/x265/files/patch-disable-avx-for-clang
new file mode 100644
index 000000000000..e09495d6a5ea
--- /dev/null
+++ b/multimedia/x265/files/patch-disable-avx-for-clang
@@ -0,0 +1,13 @@
+See:
+
+ https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229788
+ https://bitbucket.org/multicoreware/x265/issues/422/when-using-clang-with-avx-enabled
+
+--- CMakeLists.txt 2018-05-21 04:33:10.000000000 -0400
++++ CMakeLists.txt 2018-07-17 12:51:05.820330000 -0400
+@@ -133,4 +133,5 @@
+ if(${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
+ set(CLANG 1)
++ add_definitions("-mno-avx")
+ endif()
+ if(${CMAKE_CXX_COMPILER_ID} STREQUAL "Intel")