aboutsummaryrefslogtreecommitdiff
path: root/net-im/dendrite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/dendrite/Makefile')
-rw-r--r--net-im/dendrite/Makefile125
1 files changed, 76 insertions, 49 deletions
diff --git a/net-im/dendrite/Makefile b/net-im/dendrite/Makefile
index 26f3449f8953..01ff04356726 100644
--- a/net-im/dendrite/Makefile
+++ b/net-im/dendrite/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dendrite
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.11
+DISTVERSION= 0.4.1
CATEGORIES= net-im
MAINTAINER= ashish@FreeBSD.org
@@ -15,12 +15,12 @@ USE_RC_SUBR= ${PORTNAME}
USERS= ${PORTNAME}
GROUPS= ${USERS}
-DENDRITE_BINS= client-api-proxy create-account create-room-events \
- dendrite-demo-libp2p dendrite-demo-yggdrasil \
- dendrite-monolith-server dendrite-polylith-multi \
- federation-api-proxy furl generate-config \
- generate-keys goose kafka-producer \
- mediaapi-integration-tests resolve-state
+DENDRITE_BINS= client-api-proxy create-account \
+ dendrite-demo-libp2p dendrite-demo-pinecone \
+ dendrite-demo-yggdrasil dendrite-monolith-server \
+ dendrite-polylith-multi dendrite-upgrade-tests \
+ dendritejs-pinecone dendritejs federation-api-proxy furl \
+ generate-config generate-keys goose resolve-state
.for f in ${DENDRITE_BINS}
GO_TARGET+= ./cmd/$f:${PREFIX}/dendrite/bin/$f
@@ -28,37 +28,53 @@ GO_TARGET+= ./cmd/$f:${PREFIX}/dendrite/bin/$f
USE_GITHUB= yes
GH_ACCOUNT= matrix-org
-GH_TUPLE= \
- Arceliar:phony:d0c68492aca0:arceliar_phony/vendor/github.com/Arceliar/phony \
+GH_TUPLE= Arceliar:ironwood:6ad55cae5031:arceliar_ironwood/vendor/github.com/Arceliar/ironwood \
+ Arceliar:phony:dde1a8dca979:arceliar_phony/vendor/github.com/Arceliar/phony \
DATA-DOG:go-sqlmock:v1.5.0:data_dog_go_sqlmock/vendor/github.com/DATA-DOG/go-sqlmock \
- Shopify:sarama:v1.27.0:shopify_sarama/vendor/github.com/Shopify/sarama \
+ HdrHistogram:hdrhistogram-go:v1.0.1:hdrhistogram_hdrhistogram_go/vendor/github.com/HdrHistogram/hdrhistogram-go \
+ Masterminds:semver:v3.1.1:masterminds_semver_v3/vendor/github.com/Masterminds/semver/v3 \
+ Microsoft:go-winio:v0.4.17:microsoft_go_winio/vendor/github.com/Microsoft/go-winio \
+ Shopify:sarama:v1.28.0:shopify_sarama/vendor/github.com/Shopify/sarama \
beorn7:perks:v1.0.1:beorn7_perks/vendor/github.com/beorn7/perks \
btcsuite:btcd:v0.20.1-beta:btcsuite_btcd/vendor/github.com/btcsuite/btcd \
census-instrumentation:opencensus-go:v0.22.4:census_instrumentation_opencensus_go/vendor/go.opencensus.io \
cespare:xxhash:v2.1.1:cespare_xxhash_v2/vendor/github.com/cespare/xxhash/v2 \
cheekybits:genny:v1.0.0:cheekybits_genny/vendor/github.com/cheekybits/genny \
+ codeclysm:extract:v2.2.0:codeclysm_extract/vendor/github.com/codeclysm/extract \
+ containerd:containerd:v1.5.2:containerd_containerd/vendor/github.com/containerd/containerd \
davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-spew \
davidlazar:go-crypto:dcfb0a7ac018:davidlazar_go_crypto/vendor/github.com/davidlazar/go-crypto \
+ docker:distribution:v2.7.1:docker_distribution/vendor/github.com/docker/distribution \
+ docker:go-connections:v0.4.0:docker_go_connections/vendor/github.com/docker/go-connections \
+ docker:go-units:v0.4.0:docker_go_units/vendor/github.com/docker/go-units \
eapache:go-resiliency:v1.2.0:eapache_go_resiliency/vendor/github.com/eapache/go-resiliency \
eapache:go-xerial-snappy:776d5712da21:eapache_go_xerial_snappy/vendor/github.com/eapache/go-xerial-snappy \
eapache:queue:v1.1.0:eapache_queue/vendor/github.com/eapache/queue \
flynn:noise:2492fe189ae6:flynn_noise/vendor/github.com/flynn/noise \
- francoispqt:gojay:v1.2.13:francoispqt_gojay/vendor/github.com/francoispqt/gojay \
+ getsentry:sentry-go:v0.10.0:getsentry_sentry_go/vendor/github.com/getsentry/sentry-go \
go-macaroon:macaroon:v2.1.0:go_macaroon_macaroon/vendor/gopkg.in/macaroon.v2 \
- go-yaml:yaml:v2.3.0:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
- gogo:protobuf:v1.3.1:gogo_protobuf/vendor/github.com/gogo/protobuf \
- golang:crypto:eec23a3978ad:golang_crypto/vendor/golang.org/x/crypto \
- golang:net:5f4716e94777:golang_net/vendor/golang.org/x/net \
- golang:protobuf:v1.4.2:golang_protobuf/vendor/github.com/golang/protobuf \
- golang:snappy:v0.0.1:golang_snappy/vendor/github.com/golang/snappy \
- golang:sys:22da62e12c0c:golang_sys/vendor/golang.org/x/sys \
- golang:text:v0.3.5:golang_text/vendor/golang.org/x/text \
+ go-yaml:yaml:v2.4.0:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
+ gogo:protobuf:v1.3.2:gogo_protobuf/vendor/github.com/gogo/protobuf \
+ golang:crypto:a769d52b0f97:golang_crypto/vendor/golang.org/x/crypto \
+ golang:mobile:bdb1ca9a1e08:golang_mobile/vendor/golang.org/x/mobile \
+ golang:mod:v0.3.0:golang_mod/vendor/golang.org/x/mod \
+ golang:net:84b48f89b13b:golang_net/vendor/golang.org/x/net \
+ golang:protobuf:v1.4.3:golang_protobuf/vendor/github.com/golang/protobuf \
+ golang:snappy:v0.0.2:golang_snappy/vendor/github.com/golang/snappy \
+ golang:sys:0f9fa26af87c:golang_sys/vendor/golang.org/x/sys \
+ golang:term:7de9c90e9dd1:golang_term/vendor/golang.org/x/term \
+ golang:text:5c7c50ebbd4f:golang_text/vendor/golang.org/x/text \
+ golang:tools:113979e3529a:golang_tools/vendor/golang.org/x/tools \
+ golang:xerrors:5ec99f83aff1:golang_xerrors/vendor/golang.org/x/xerrors \
gologme:log:v1.2.0:gologme_log/vendor/github.com/gologme/log \
+ google:go-genproto:8816d57aaa9a:google_go_genproto/vendor/google.golang.org/genproto \
google:gopacket:v1.1.18:google_gopacket/vendor/github.com/google/gopacket \
- google:uuid:v1.1.2:google_uuid/vendor/github.com/google/uuid \
+ google:uuid:v1.2.0:google_uuid/vendor/github.com/google/uuid \
gorilla:mux:v1.8.0:gorilla_mux/vendor/github.com/gorilla/mux \
gorilla:websocket:v1.4.2:gorilla_websocket/vendor/github.com/gorilla/websocket \
- h2non:bimg:v1.1.4:h2non_bimg/vendor/gopkg.in/h2non/bimg.v1 \
+ grpc:grpc-go:v1.33.2:grpc_grpc_go/vendor/google.golang.org/grpc \
+ h2non:bimg:v1.1.5:h2non_bimg/vendor/gopkg.in/h2non/bimg.v1 \
+ h2non:filetype:v1.1.1:h2non_filetype/vendor/github.com/h2non/filetype \
hashicorp:errwrap:v1.0.0:hashicorp_errwrap/vendor/github.com/hashicorp/errwrap \
hashicorp:go-multierror:v1.1.0:hashicorp_go_multierror/vendor/github.com/hashicorp/go-multierror \
hashicorp:go-uuid:v1.0.2:hashicorp_go_uuid/vendor/github.com/hashicorp/go-uuid \
@@ -73,14 +89,16 @@ GH_TUPLE= \
jackpal:go-nat-pmp:v1.0.2:jackpal_go_nat_pmp/vendor/github.com/jackpal/go-nat-pmp \
jbenet:go-temp-err-catcher:v0.1.0:jbenet_go_temp_err_catcher/vendor/github.com/jbenet/go-temp-err-catcher \
jbenet:goprocess:v0.1.4:jbenet_goprocess/vendor/github.com/jbenet/goprocess \
- jcmturner:aescts:v1.0.1:jcmturner_aescts/vendor/gopkg.in/jcmturner/aescts.v1 \
- jcmturner:dnsutils:v1.0.1:jcmturner_dnsutils/vendor/gopkg.in/jcmturner/dnsutils.v1 \
+ jcmturner:aescts:v2.0.0:jcmturner_aescts_v2/vendor/github.com/jcmturner/aescts \
+ jcmturner:dnsutils:v2.0.0:jcmturner_dnsutils_v2/vendor/github.com/jcmturner/dnsutils \
jcmturner:gofork:v1.0.0:jcmturner_gofork/vendor/github.com/jcmturner/gofork \
- jcmturner:gokrb5:v7.5.0:jcmturner_gokrb5/vendor/gopkg.in/jcmturner/gokrb5.v7 \
- jcmturner:rpc:v1.1.0:jcmturner_rpc/vendor/gopkg.in/jcmturner/rpc.v1 \
- klauspost:compress:v1.10.10:klauspost_compress/vendor/github.com/klauspost/compress \
+ jcmturner:gokrb5:v8.4.2:jcmturner_gokrb5_v8/vendor/github.com/jcmturner/gokrb5 \
+ jcmturner:rpc:v2.0.3:jcmturner_rpc_v2/vendor/github.com/jcmturner/rpc \
+ juju:errors:3fe23663418f:juju_errors/vendor/github.com/juju/errors \
+ juju:testing:18c50b0c2098:juju_testing/vendor/github.com/juju/testing \
+ klauspost:compress:v1.11.13:klauspost_compress/vendor/github.com/klauspost/compress \
koron:go-ssdp:2e1c40ed0b5d:koron_go_ssdp/vendor/github.com/koron/go-ssdp \
- lib:pq:v1.8.0:lib_pq/vendor/github.com/lib/pq \
+ lib:pq:v1.9.0:lib_pq/vendor/github.com/lib/pq \
libp2p:go-addr-util:v0.0.2:libp2p_go_addr_util/vendor/github.com/libp2p/go-addr-util \
libp2p:go-buffer-pool:v0.0.2:libp2p_go_buffer_pool/vendor/github.com/libp2p/go-buffer-pool \
libp2p:go-cidranger:v1.1.0:libp2p_go_cidranger/vendor/github.com/libp2p/go-cidranger \
@@ -122,20 +140,24 @@ GH_TUPLE= \
libp2p:go-tcp-transport:v0.2.1:libp2p_go_tcp_transport/vendor/github.com/libp2p/go-tcp-transport \
libp2p:go-ws-transport:v0.4.0:libp2p_go_ws_transport/vendor/github.com/libp2p/go-ws-transport \
libp2p:go-yamux:v2.0.0:libp2p_go_yamux_v2/vendor/github.com/libp2p/go-yamux/v2 \
- lucas-clemente:quic-go:v0.17.3:lucas_clemente_quic_go/vendor/github.com/lucas-clemente/quic-go \
- marten-seemann:qtls:v0.9.1:marten_seemann_qtls/vendor/github.com/marten-seemann/qtls \
+ lucas-clemente:quic-go:v0.19.3:lucas_clemente_quic_go/vendor/github.com/lucas-clemente/quic-go \
+ marten-seemann:qtls-go1-15:v0.1.1:marten_seemann_qtls_go1_15/vendor/github.com/marten-seemann/qtls-go1-15 \
+ marten-seemann:qtls:v0.10.0:marten_seemann_qtls/vendor/github.com/marten-seemann/qtls \
matrix-org:dugong:51a565b5666b:matrix_org_dugong/vendor/github.com/matrix-org/dugong \
matrix-org:go-http-js-libp2p:783164aeeda4:matrix_org_go_http_js_libp2p/vendor/github.com/matrix-org/go-http-js-libp2p \
- matrix-org:go-sqlite3-js:bc8506ccbcf3:matrix_org_go_sqlite3_js/vendor/github.com/matrix-org/go-sqlite3-js \
- matrix-org:gomatrix:7dd5e2a05bcd:matrix_org_gomatrix/vendor/github.com/matrix-org/gomatrix \
- matrix-org:gomatrixserverlib:bab1f2be20d0:matrix_org_gomatrixserverlib/vendor/github.com/matrix-org/gomatrixserverlib \
- matrix-org:naffka:bcdd62999a91:matrix_org_naffka/vendor/github.com/matrix-org/naffka \
+ matrix-org:go-sqlite3-js:b0d1ba599a6d:matrix_org_go_sqlite3_js/vendor/github.com/matrix-org/go-sqlite3-js \
+ matrix-org:gomatrix:be2af5ef2e16:matrix_org_gomatrix/vendor/github.com/matrix-org/gomatrix \
+ matrix-org:gomatrixserverlib:5061d6986876:matrix_org_gomatrixserverlib/vendor/github.com/matrix-org/gomatrixserverlib \
+ matrix-org:naffka:14ff508b58e0:matrix_org_naffka/vendor/github.com/matrix-org/naffka \
+ matrix-org:pinecone:74f885644c1b:matrix_org_pinecone/vendor/github.com/matrix-org/pinecone \
matrix-org:util:55161520e1d4:matrix_org_util/vendor/github.com/matrix-org/util \
- mattn:go-sqlite3:v1.14.2:mattn_go_sqlite3/vendor/github.com/mattn/go-sqlite3 \
- matttproud:golang_protobuf_extensions:v1.0.1:matttproud_golang_protobuf_extensions/vendor/github.com/matttproud/golang_protobuf_extensions \
+ mattn:go-sqlite3:1157a4212dcb:mattn_go_sqlite3/vendor/github.com/mattn/go-sqlite3 \
+ matttproud:golang_protobuf_extensions:c182affec369:matttproud_golang_protobuf_extensions/vendor/github.com/matttproud/golang_protobuf_extensions \
miekg:dns:v1.1.31:miekg_dns/vendor/github.com/miekg/dns \
minio:blake2b-simd:3f5f724cb5b1:minio_blake2b_simd/vendor/github.com/minio/blake2b-simd \
minio:sha256-simd:v0.1.1:minio_sha256_simd/vendor/github.com/minio/sha256-simd \
+ moby:moby:v20.10.7:moby_moby/vendor/github.com/docker/docker \
+ morikuni:aec:v1.0.0:morikuni_aec/vendor/github.com/morikuni/aec \
mr-tron:base58:v1.2.0:mr_tron_base58/vendor/github.com/mr-tron/base58 \
multiformats:go-base32:v0.0.3:multiformats_go_base32/vendor/github.com/multiformats/go-base32 \
multiformats:go-base36:v0.1.0:multiformats_go_base36/vendor/github.com/multiformats/go-base36 \
@@ -147,35 +169,40 @@ GH_TUPLE= \
multiformats:go-multihash:v0.0.14:multiformats_go_multihash/vendor/github.com/multiformats/go-multihash \
multiformats:go-multistream:v0.2.0:multiformats_go_multistream/vendor/github.com/multiformats/go-multistream \
multiformats:go-varint:v0.0.6:multiformats_go_varint/vendor/github.com/multiformats/go-varint \
+ neilalexander:utp:52626cdf31b2:neilalexander_utp/vendor/github.com/neilalexander/utp \
nfnt:resize:83c6a9932646:nfnt_resize/vendor/github.com/nfnt/resize \
ngrok:sqlmw:d5c93a81bec6:ngrok_sqlmw/vendor/github.com/ngrok/sqlmw \
+ nhooyr:websocket:v1.8.7:nhooyr_websocket/vendor/nhooyr.io/websocket \
+ opencontainers:go-digest:v1.0.0:opencontainers_go_digest/vendor/github.com/opencontainers/go-digest \
+ opencontainers:image-spec:v1.0.1:opencontainers_image_spec/vendor/github.com/opencontainers/image-spec \
opentracing:opentracing-go:v1.2.0:opentracing_opentracing_go/vendor/github.com/opentracing/opentracing-go \
- pierrec:lz4:v2.5.2:pierrec_lz4/vendor/github.com/pierrec/lz4 \
+ patrickmn:go-cache:v2.1.0:patrickmn_go_cache/vendor/github.com/patrickmn/go-cache \
+ pierrec:lz4:v2.6.0:pierrec_lz4/vendor/github.com/pierrec/lz4 \
pkg:errors:v0.9.1:pkg_errors/vendor/github.com/pkg/errors \
- pressly:goose:v2.7.0-rc5:pressly_goose/vendor/github.com/pressly/goose \
- prometheus:client_golang:v1.7.1:prometheus_client_golang/vendor/github.com/prometheus/client_golang \
+ pressly:goose:v2.7.0:pressly_goose/vendor/github.com/pressly/goose \
+ prometheus:client_golang:v1.9.0:prometheus_client_golang/vendor/github.com/prometheus/client_golang \
prometheus:client_model:v0.2.0:prometheus_client_model/vendor/github.com/prometheus/client_model \
- prometheus:common:v0.10.0:prometheus_common/vendor/github.com/prometheus/common \
- prometheus:procfs:v0.1.3:prometheus_procfs/vendor/github.com/prometheus/procfs \
- protocolbuffers:protobuf-go:v1.23.0:protocolbuffers_protobuf_go/vendor/google.golang.org/protobuf \
- rcrowley:go-metrics:10cdbea86bc0:rcrowley_go_metrics/vendor/github.com/rcrowley/go-metrics \
- sirupsen:logrus:v1.7.0:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
+ prometheus:common:v0.15.0:prometheus_common/vendor/github.com/prometheus/common \
+ prometheus:procfs:v0.6.0:prometheus_procfs/vendor/github.com/prometheus/procfs \
+ protocolbuffers:protobuf-go:v1.25.0:protocolbuffers_protobuf_go/vendor/google.golang.org/protobuf \
+ rcrowley:go-metrics:cf1acfcdf475:rcrowley_go_metrics/vendor/github.com/rcrowley/go-metrics \
+ sirupsen:logrus:v1.8.1:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
spacemonkeygo:spacelog:2296661a0572:spacemonkeygo_spacelog/vendor/github.com/spacemonkeygo/spacelog \
spaolacci:murmur3:v1.1.0:spaolacci_murmur3/vendor/github.com/spaolacci/murmur3 \
- tidwall:gjson:v1.6.7:tidwall_gjson/vendor/github.com/tidwall/gjson \
+ tidwall:gjson:v1.8.1:tidwall_gjson/vendor/github.com/tidwall/gjson \
tidwall:match:v1.0.3:tidwall_match/vendor/github.com/tidwall/match \
- tidwall:pretty:v1.0.2:tidwall_pretty/vendor/github.com/tidwall/pretty \
- tidwall:sjson:v1.1.4:tidwall_sjson/vendor/github.com/tidwall/sjson \
- uber-go:atomic:v1.6.0:uber_go_atomic/vendor/go.uber.org/atomic \
+ tidwall:pretty:v1.2.0:tidwall_pretty/vendor/github.com/tidwall/pretty \
+ tidwall:sjson:v1.1.7:tidwall_sjson/vendor/github.com/tidwall/sjson \
+ uber-go:atomic:v1.7.0:uber_go_atomic/vendor/go.uber.org/atomic \
uber-go:multierr:v1.5.0:uber_go_multierr/vendor/go.uber.org/multierr \
uber-go:zap:v1.16.0:uber_go_zap/vendor/go.uber.org/zap \
uber:jaeger-client-go:v2.25.0:uber_jaeger_client_go/vendor/github.com/uber/jaeger-client-go \
- uber:jaeger-lib:v2.2.0:uber_jaeger_lib/vendor/github.com/uber/jaeger-lib \
+ uber:jaeger-lib:v2.4.0:uber_jaeger_lib/vendor/github.com/uber/jaeger-lib \
whyrusleeping:go-keyspace:5b898ac5add1:whyrusleeping_go_keyspace/vendor/github.com/whyrusleeping/go-keyspace \
whyrusleeping:mdns:b9b60ed33aa9:whyrusleeping_mdns/vendor/github.com/whyrusleeping/mdns \
whyrusleeping:multiaddr-filter:e903e4adabd7:whyrusleeping_multiaddr_filter/vendor/github.com/whyrusleeping/multiaddr-filter \
whyrusleeping:timecache:cfcb2f1abfee:whyrusleeping_timecache/vendor/github.com/whyrusleeping/timecache \
- yggdrasil-network:yggdrasil-go:e77ca8019daa:yggdrasil_network_yggdrasil_go/vendor/github.com/yggdrasil-network/yggdrasil-go
+ yggdrasil-network:yggdrasil-go:52309d094c00:yggdrasil_network_yggdrasil_go/vendor/github.com/yggdrasil-network/yggdrasil-go
post-build:
cd ${WRKSRC} && \