aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-sipe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin-sipe/Makefile')
-rw-r--r--net-im/pidgin-sipe/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/net-im/pidgin-sipe/Makefile b/net-im/pidgin-sipe/Makefile
index d87e1bb11a84..2b85bda2d486 100644
--- a/net-im/pidgin-sipe/Makefile
+++ b/net-im/pidgin-sipe/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pidgin-sipe
-PORTVERSION= 1.9.1
-PORTREVISION= 1
+PORTVERSION= 1.10.0
CATEGORIES= net-im
MASTER_SITES= SF/sipe/sipe/${DISTNAME}
@@ -22,11 +21,15 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gtk20
USE_LDCONFIG= ${PREFIX}/lib/pidgin
-USE_GETTEXT= yes
+PORTDOCS= AUTHORS ChangeLog COPYING HACKING INSTALL NEWS README TODO VERSION
CFLAGS+= "-I/${LOCALBASE}/include"
LIBS+= "-L/${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --enable-purple \
+ --disable-telepathy \
+ --without-krb5
+
CONFIGURE_ENV+= LIBS="${LIBS}" \
COM_ERR_CFLAGS="-I/usr/include" \
COM_ERR_LIBS="-L/usr/lib -lcom_err"
@@ -34,9 +37,17 @@ CONFIGURE_ENV+= LIBS="${LIBS}" \
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
-.for f in AUTHORS ChangeLog COPYING HACKING INSTALL NEWS README TODO
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}/
.endfor
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.include <bsd.port.mk>