aboutsummaryrefslogtreecommitdiff
path: root/net-im/tut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/tut/Makefile')
-rw-r--r--net-im/tut/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/net-im/tut/Makefile b/net-im/tut/Makefile
index b2bd12379bc5..2490a874d8f4 100644
--- a/net-im/tut/Makefile
+++ b/net-im/tut/Makefile
@@ -1,5 +1,5 @@
PORTNAME= tut
-DISTVERSION= 0.0.33
+DISTVERSION= 0.0.35
CATEGORIES= net-im
MAINTAINER= lcook@FreeBSD.org
@@ -16,15 +16,15 @@ GH_TUPLE= atotto:clipboard:v0.1.4:atotto_clipboard/vendor/github.com/atotto/clip
gdamore:encoding:v1.0.0:gdamore_encoding/vendor/github.com/gdamore/encoding \
gdamore:tcell:f057f0a857a1:gdamore_tcell_v2/vendor/github.com/gdamore/tcell/v2 \
gen2brain:beeep:5586760f0cc1:gen2brain_beeep/vendor/github.com/gen2brain/beeep \
- go-ini:ini:v1.63.0:go_ini_ini/vendor/gopkg.in/ini.v1 \
+ go-ini:ini:v1.63.2:go_ini_ini/vendor/gopkg.in/ini.v1 \
go-toast:toast:01e6764cf0a4:go_toast_toast/vendor/github.com/go-toast/toast \
gobwas:glob:v0.2.3:gobwas_glob/vendor/github.com/gobwas/glob \
godbus:dbus:v5.0.5:godbus_dbus_v5/vendor/github.com/godbus/dbus/v5 \
- golang:net:a5e095526f91:golang_net/vendor/golang.org/x/net \
- golang:sys:751e447fb3d0:golang_sys/vendor/golang.org/x/sys \
- golang:term:6886f2dfbf5b:golang_term/vendor/golang.org/x/term \
+ golang:net:e81a3d93ecf6:golang_net/vendor/golang.org/x/net \
+ golang:sys:808efd93c36d:golang_sys/vendor/golang.org/x/sys \
+ golang:term:03fcf44c2211:golang_term/vendor/golang.org/x/term \
golang:text:v0.3.7:golang_text/vendor/golang.org/x/text \
- gopherjs:gopherjs:eee08aaf2717:gopherjs_gopherjs/vendor/github.com/gopherjs/gopherjs \
+ gopherjs:gopherjs:a930101f3d15:gopherjs_gopherjs/vendor/github.com/gopherjs/gopherjs \
gopherjs:gopherwasm:v1.1.0:gopherjs_gopherwasm/vendor/github.com/gopherjs/gopherwasm \
gorilla:css:v1.0.0:gorilla_css/vendor/github.com/gorilla/css \
gorilla:websocket:v1.4.2:gorilla_websocket/vendor/github.com/gorilla/websocket \
@@ -36,19 +36,25 @@ GH_TUPLE= atotto:clipboard:v0.1.4:atotto_clipboard/vendor/github.com/atotto/clip
microcosm-cc:bluemonday:v1.0.15:microcosm_cc_bluemonday/vendor/github.com/microcosm-cc/bluemonday \
nu7hatch:gouuid:179d4d0c4d8d:nu7hatch_gouuid/vendor/github.com/nu7hatch/gouuid \
pelletier:go-toml:v2.0.0-beta.3:pelletier_go_toml_v2/vendor/github.com/pelletier/go-toml/v2 \
- rivo:tview:f7430b878d17:rivo_tview/vendor/github.com/rivo/tview \
+ rivo:tview:5508f4b00266:rivo_tview/vendor/github.com/rivo/tview \
rivo:uniseg:v0.2.0:rivo_uniseg/vendor/github.com/rivo/uniseg \
tadvi:systray:11a2b8fa57af:tadvi_systray/vendor/github.com/tadvi/systray \
tomnomnom:linkheader:02ca5825eb80:tomnomnom_linkheader/vendor/github.com/tomnomnom/linkheader
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README.md
+PORTEXAMPLES= toot.tmpl
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} \
${STAGEDIR}${DOCSDIR}
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} \
+ ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.mk>