aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/aircrack-ng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/aircrack-ng/Makefile')
-rw-r--r--net-mgmt/aircrack-ng/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net-mgmt/aircrack-ng/Makefile b/net-mgmt/aircrack-ng/Makefile
index 899d57c31ad5..e5ba79395193 100644
--- a/net-mgmt/aircrack-ng/Makefile
+++ b/net-mgmt/aircrack-ng/Makefile
@@ -16,7 +16,7 @@ BROKEN_aarch64= fails to configure: _AX_COMPILER_VERSION_GNU unknown gcc major
BROKEN_armv6= fails to configure: _AX_COMPILER_VERSION_GNU unknown gcc major
BROKEN_armv7= fails to configure: _AX_COMPILER_VERSION_GNU unknown gcc major
-USES= autoreconf cpe dos2unix gmake libtool ssl
+USES= autoreconf cpe dos2unix gmake libtool pkgconfig
USE_GCC= yes
USE_LDCONFIG= yes
@@ -25,21 +25,24 @@ CONFIGURE_ARGS= --with-experimental
CPE_VERSION= ${DISTVERSION:C/-.*//}
CPE_UPDATE= ${DISTVERSION:C/^[^-]*$//:C/.*-//}
DOS2UNIX_FILES= src/aircrack-osdep/byteorder.h
-CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= HWLOC PCRE SQLITE
+OPTIONS_DEFINE= GCRYPT HWLOC PCRE SQLITE
OPTIONS_DEFAULT= HWLOC PCRE SQLITE
OPTIONS_SUB= yes
+GCRYPT_LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error
+GCRYPT_CONFIGURE_ON= --with-gcrypt
+GCRYPT_USES_OFF= ssl
+GCRYPT_VARS_OFF= CFLAGS+=-I${OPENSSLINC} LDFLAGS+=-L${OPENSSLLIB}
+
HWLOC_DESC= Use Hardware Locality to improve performance
HWLOC_LIB_DEPENDS= libhwloc.so:devel/hwloc2
HWLOC_CONFIGURE_OFF= --disable-hwloc
PCRE_DESC= Use Perl Compatible Regular Expressions for wesside
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
-PCRE_USES= pkgconfig
PCRE_CONFIGURE_OFF= --disable-pcre
SQLITE_DESC= Use SQLite for storing pre-computed key tables