aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/fastnetmon/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/fastnetmon/files')
-rw-r--r--net-mgmt/fastnetmon/files/fastnetmon.in2
-rw-r--r--net-mgmt/fastnetmon/files/patch-CMakeLists.txt30
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp4
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.84
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_netmap__plugin_netmap__collector.cpp4
5 files changed, 37 insertions, 7 deletions
diff --git a/net-mgmt/fastnetmon/files/fastnetmon.in b/net-mgmt/fastnetmon/files/fastnetmon.in
index c6ee5b2aa52e..598dbc0382d8 100644
--- a/net-mgmt/fastnetmon/files/fastnetmon.in
+++ b/net-mgmt/fastnetmon/files/fastnetmon.in
@@ -24,7 +24,7 @@ load_rc_config "$name"
: ${fastnetmon_user:=fastnetmon}
command=%%PREFIX%%/bin/fastnetmon
-command_args="--daemonize --configuration_file ${fastnetmon_conf} ${fastnetmon_flags}"
+command_args="--daemonize --configuration_file ${fastnetmon_conf} --pid_logic ${fastnetmon_flags}"
pidfile=/var/run/fastnetmon/$name.pid
run_rc_command "$1"
diff --git a/net-mgmt/fastnetmon/files/patch-CMakeLists.txt b/net-mgmt/fastnetmon/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d833ac56fc9d
--- /dev/null
+++ b/net-mgmt/fastnetmon/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+--- CMakeLists.txt.orig 2023-10-14 15:48:26 UTC
++++ CMakeLists.txt
+@@ -47,7 +47,8 @@ set(GTEST_INSTALL_PATH "${FASTNETMON_LIBRARIES_GLOBAL_
+ # In order to get a warning about an unused function parameter, you must either specify -Wextra -Wunused (note that -Wall implies -Wunused), or separately specify -Wunused-parameter.
+ # TODO: return -Wunused-parameter and address all warning later, I started it but did not finish as we have too many of them
+ # catch-value is documented here: https://patchwork.ozlabs.org/project/gcc/patch/tkrat.8c7b4260a533be2f@netcologne.de/#1680619
+-add_definitions("-Wreorder -Wunused -Wparentheses -Wimplicit-fallthrough -Wreturn-type -Wuninitialized -Winit-self -Wmaybe-uninitialized -Wcatch-value=3 -Wclass-memaccess")
++# add_definitions("-Wreorder -Wunused -Wparentheses -Wimplicit-fallthrough -Wreturn-type -Wuninitialized -Winit-self -Wmaybe-uninitialized -Wcatch-value=3 -Wclass-memaccess")
++add_definitions("-Wreorder -Wunused -Wparentheses -Wimplicit-fallthrough -Wreturn-type -Wuninitialized -Winit-self")
+
+ # On Windows we need to build libgcc and libstdc++ statically to avoid need to carry dlls with us
+ if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+@@ -81,7 +82,7 @@ option(KAFKA_SUPPORT "Enables Kafka support" OFF)
+ option(KAFKA_SUPPORT "Enables Kafka support" OFF)
+
+ # We need to add it into include path as gRPC uses it include path
+-include_directories("${ABSL_INSTALL_PATH}/include")
++# include_directories("${ABSL_INSTALL_PATH}/include")
+
+ option(DO_NOT_USE_SYSTEM_LIBRARIES_FOR_BUILD "Disables use of libraries from system path" OFF)
+
+@@ -848,7 +849,7 @@ if (ENABLE_CAPNP_SUPPORT)
+ message(FATAL_ERROR "Could not find capnp libraries")
+ endif()
+
+- include_directories("${CAPNP_CUSTOM_INSTALL_PATH}/include")
++ # include_directories("${CAPNP_CUSTOM_INSTALL_PATH}/include")
+
+ target_link_libraries(simple_packet_capnp ${CAPNP_LIBRARY_PATH} ${CAPNP_KJ_LIBRARY_PATH})
+
diff --git a/net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp b/net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp
index 0883c1581808..74155be61ca9 100644
--- a/net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp
+++ b/net-mgmt/fastnetmon/files/patch-src_fastnetmon.cpp
@@ -1,5 +1,5 @@
---- src/fastnetmon.cpp.orig 2023-05-23 06:20:59 UTC
-+++ src/fastnetmon.cpp
+--- fastnetmon.cpp.orig 2023-05-23 06:20:59 UTC
++++ fastnetmon.cpp
@@ -156,7 +156,7 @@ unsigned int stats_thread_initial_call_delay = 30;
std::string reporting_server = "community-stats.fastnetmon.com";
diff --git a/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.8 b/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.8
index bb43f4f3a050..75d8a25831a5 100644
--- a/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.8
+++ b/net-mgmt/fastnetmon/files/patch-src_man_fastnetmon.8
@@ -1,5 +1,5 @@
---- src/man/fastnetmon.8.orig 2023-03-03 16:20:18 UTC
-+++ src/man/fastnetmon.8
+--- man/fastnetmon.8.orig 2023-03-03 16:20:18 UTC
++++ man/fastnetmon.8
@@ -8,7 +8,7 @@ fastnetmon [--daemonize]
.SH DESCRIPTION
FastNetMon - a high performance DoS/DDoS load analyzer built on top of multiple packet capture engines (NetFlow, IPFIX, sFlow, port mirror).
diff --git a/net-mgmt/fastnetmon/files/patch-src_netmap__plugin_netmap__collector.cpp b/net-mgmt/fastnetmon/files/patch-src_netmap__plugin_netmap__collector.cpp
index 19a3f3d8b17d..1bc5cd90e69f 100644
--- a/net-mgmt/fastnetmon/files/patch-src_netmap__plugin_netmap__collector.cpp
+++ b/net-mgmt/fastnetmon/files/patch-src_netmap__plugin_netmap__collector.cpp
@@ -1,5 +1,5 @@
---- src/netmap_plugin/netmap_collector.cpp.orig 2023-03-01 14:23:34 UTC
-+++ src/netmap_plugin/netmap_collector.cpp
+--- netmap_plugin/netmap_collector.cpp.orig 2023-03-01 14:23:34 UTC
++++ netmap_plugin/netmap_collector.cpp
@@ -19,6 +19,7 @@
// Disable debug messages from Netmap