aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ndpmon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/ndpmon/Makefile')
-rw-r--r--net-mgmt/ndpmon/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
new file mode 100644
index 000000000000..844843701d4a
--- /dev/null
+++ b/net-mgmt/ndpmon/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: ndpmon
+# Date created: 2006-12-17
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ndpmon
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt ipv6
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-${PORTVERSION}b.tgz
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= On-link icmpv6 message monitoring and reporting daemon
+
+USE_GNOME= libxml2
+
+GNU_CONFIGURE= yes
+
+MAN8= ndpmon.8
+PORTDOCS= INSTALL README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/ndpmon.c \
+ ${WRKSRC}/ndpmon.8 \
+ ${WRKSRC}/config_ndpmon.xml \
+ ${WRKSRC}/neighbor_list.xml
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/ndpmon.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/ndpmon ${PREFIX}/sbin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.dtd \
+ ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/config_ndpmon.xml ${PREFIX}/etc/config_ndpmon.xml-dist
+ ${MKDIR} ${PREFIX}/var
+ ${INSTALL_DATA} ${WRKSRC}/neighbor_list.xml ${PREFIX}/var/ndpmon_neighbor_list.xml
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>