aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/smokeping/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/smokeping/Makefile')
-rw-r--r--net-mgmt/smokeping/Makefile48
1 files changed, 24 insertions, 24 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index de0476d8dbd6..8de63b5d1afb 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -13,22 +13,22 @@ COMMENT= Latency logging and graphing system
LICENSE= GPLv2
-LIB_DEPENDS= librrd.so:${PORTSDIR}/databases/rrdtool
-BUILD_DEPENDS= p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
- p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
- p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
- p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
- p5-IO-Pty-Easy>=0:${PORTSDIR}/devel/p5-IO-Pty-Easy \
- p5-SNMP_Session>=0:${PORTSDIR}/net-mgmt/p5-SNMP_Session \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-CGI>=0:${PORTSDIR}/www/p5-CGI \
- p5-FCGI>=0:${PORTSDIR}/www/p5-FCGI \
- p5-Config-Grammar>=0:${PORTSDIR}/devel/p5-Config-Grammar \
- p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6 \
- p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
- p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet \
- p5-Net-OpenSSH>=0:${PORTSDIR}/net/p5-Net-OpenSSH \
- p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
+LIB_DEPENDS= librrd.so:databases/rrdtool
+BUILD_DEPENDS= p5-CGI-Session>=0:www/p5-CGI-Session \
+ p5-Digest-HMAC>=0:security/p5-Digest-HMAC \
+ p5-Net-SNMP>=0:net-mgmt/p5-Net-SNMP \
+ p5-Net-DNS>=0:dns/p5-Net-DNS \
+ p5-IO-Pty-Easy>=0:devel/p5-IO-Pty-Easy \
+ p5-SNMP_Session>=0:net-mgmt/p5-SNMP_Session \
+ p5-libwww>=0:www/p5-libwww \
+ p5-CGI>=0:www/p5-CGI \
+ p5-FCGI>=0:www/p5-FCGI \
+ p5-Config-Grammar>=0:devel/p5-Config-Grammar \
+ p5-Socket6>=0:net/p5-Socket6 \
+ p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL \
+ p5-Net-Telnet>=0:net/p5-Net-Telnet \
+ p5-Net-OpenSSH>=0:net/p5-Net-OpenSSH \
+ p5-perl-ldap>=0:net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
@@ -63,18 +63,18 @@ DNS_DESC= Support for AnotherDNS probes
OPTIONS_DEFINE= ECHOPING CURL RADIUS TELNET DNS FPING
OPTIONS_DEFAULT= FPING
-FPING_RUN_DEPENDS= ${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping
-ECHOPING_RUN_DEPENDS= ${LOCALBASE}/bin/echoping:${PORTSDIR}/net/echoping
-CURL_RUN_DEPENDS= ${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
-RADIUS_RUN_DEPENDS= p5-Authen-Radius>=0:${PORTSDIR}/security/p5-Authen-Radius
-TELNET_RUN_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet
-DNS_RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
+FPING_RUN_DEPENDS= ${LOCALBASE}/sbin/fping:net/fping
+ECHOPING_RUN_DEPENDS= ${LOCALBASE}/bin/echoping:net/echoping
+CURL_RUN_DEPENDS= ${LOCALBASE}/bin/curl:ftp/curl
+RADIUS_RUN_DEPENDS= p5-Authen-Radius>=0:security/p5-Authen-Radius
+TELNET_RUN_DEPENDS= p5-Net-Telnet>=0:net/p5-Net-Telnet
+DNS_RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502100
-BUILD_DEPENDS+= p5-CGI-Fast>=0:${PORTSDIR}/www/p5-CGI-Fast
-RUN_DEPENDS+= p5-CGI-Fast>=0:${PORTSDIR}/www/p5-CGI-Fast
+BUILD_DEPENDS+= p5-CGI-Fast>=0:www/p5-CGI-Fast
+RUN_DEPENDS+= p5-CGI-Fast>=0:www/p5-CGI-Fast
.endif
# We will take these from CPAN instead