aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/xymon-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/xymon-client/Makefile')
-rw-r--r--net-mgmt/xymon-client/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-mgmt/xymon-client/Makefile b/net-mgmt/xymon-client/Makefile
index 8432be3d2205..104b772864d2 100644
--- a/net-mgmt/xymon-client/Makefile
+++ b/net-mgmt/xymon-client/Makefile
@@ -25,6 +25,7 @@ MAKE_ENV+= BBUSER="${BBUSER}"
MAKE_ENV+= BBHOSTIP="${BBHOSTIP}"
USE_RC_SUBR= hobbit-client.sh
PLIST_SUB+= BBUSER="${BBUSER}"
+CONFIG_FILES= clientlaunch.cfg hobbitclient.cfg localclient.cfg
# Configure script is interactive
do-configure:
@@ -35,4 +36,10 @@ pre-install:
if ! pw usershow ${BBUSER}; then pw useradd ${BBUSER} -g ${BBUSER} -u 280 \
-h - -d ${NONEXISTENT} -s /usr/sbin/nologin -c "Hobbit Monitor"; fi
+post-install:
+.for i in ${CONFIG_FILES}
+ ${CP} -np ${WWWDIR}/client/etc/${i}-dist \
+ ${WWWDIR}/client/etc/${i}
+.endfor
+
.include <bsd.port.mk>