aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/2ping/Makefile2
-rw-r--r--net-mgmt/Makefile2
-rw-r--r--net-mgmt/crmsh/Makefile9
-rw-r--r--net-mgmt/flowd/Makefile2
-rw-r--r--net-mgmt/nagstamon/Makefile2
-rw-r--r--net-mgmt/net-snmp/Makefile4
-rw-r--r--net-mgmt/onionlauncher/Makefile4
-rw-r--r--net-mgmt/py-adal/Makefile8
-rw-r--r--net-mgmt/py-dnsdiag/Makefile (renamed from net-mgmt/py3-dnsdiag/Makefile)13
-rw-r--r--net-mgmt/py-dnsdiag/distinfo (renamed from net-mgmt/py3-dnsdiag/distinfo)0
-rw-r--r--net-mgmt/py-dnsdiag/pkg-descr (renamed from net-mgmt/py3-dnsdiag/pkg-descr)0
-rw-r--r--net-mgmt/py-ipcalc/Makefile2
-rw-r--r--net-mgmt/py-ipcalc/pkg-plist3
-rw-r--r--net-mgmt/py-msrest/Makefile10
-rw-r--r--net-mgmt/py-msrestazure/Makefile6
-rw-r--r--net-mgmt/py-pynsca/Makefile6
-rw-r--r--net-mgmt/py-pysmi/Makefile2
-rw-r--r--net-mgmt/py-pyzabbix/Makefile2
-rw-r--r--net-mgmt/py-snmp4-apps/Makefile2
-rw-r--r--net-mgmt/py-snmp4-mibs/Makefile2
-rw-r--r--net-mgmt/py-snmp4/Makefile4
-rw-r--r--net-mgmt/seafile-client/Makefile4
-rw-r--r--net-mgmt/seafile-server/Makefile4
-rw-r--r--net-mgmt/tornova/Makefile2
-rw-r--r--net-mgmt/wmi-client/Makefile2
25 files changed, 44 insertions, 53 deletions
diff --git a/net-mgmt/2ping/Makefile b/net-mgmt/2ping/Makefile
index b1bf0e92423d..71ff48653f9a 100644
--- a/net-mgmt/2ping/Makefile
+++ b/net-mgmt/2ping/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
NO_ARCH= yes
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist distutils optsuffix
USES= python:3.4+
.include <bsd.port.mk>
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 85add0b92874..f16c92cd44f0 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -298,6 +298,7 @@
SUBDIR += prometheus
SUBDIR += pushgateway
SUBDIR += py-adal
+ SUBDIR += py-dnsdiag
SUBDIR += py-ipcalc
SUBDIR += py-ipy
SUBDIR += py-msrest
@@ -312,7 +313,6 @@
SUBDIR += py-snmp4-mibs
SUBDIR += py-snmp_passpersist
SUBDIR += py-yapsnmp
- SUBDIR += py3-dnsdiag
SUBDIR += qkismet
SUBDIR += rackmonkey
SUBDIR += rancid3
diff --git a/net-mgmt/crmsh/Makefile b/net-mgmt/crmsh/Makefile
index 49f16539773f..3248b69a5286 100644
--- a/net-mgmt/crmsh/Makefile
+++ b/net-mgmt/crmsh/Makefile
@@ -13,15 +13,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
# Set the build/run depends on setuptools instead of adding distutils to USE_PYTHON
# because the crmsh build uses autotools which then calls setup.py.
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
- ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= ClusterLabs
USES= autoreconf gmake python:2 shebangfix
+USE_PYTHON= flavors
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ocf-root=${PREFIX}/lib/ocf
NO_ARCH= yes
diff --git a/net-mgmt/flowd/Makefile b/net-mgmt/flowd/Makefile
index 9e045454b551..688dd7dfc1c5 100644
--- a/net-mgmt/flowd/Makefile
+++ b/net-mgmt/flowd/Makefile
@@ -34,7 +34,7 @@ USE_PERL5+= build run
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USES+= python
+USES+= python:2.7
PLIST_SUB+= PYTHON_VER=${PYTHON_VER}
.endif
diff --git a/net-mgmt/nagstamon/Makefile b/net-mgmt/nagstamon/Makefile
index 8db697e0b43a..8eea9b4e6142 100644
--- a/net-mgmt/nagstamon/Makefile
+++ b/net-mgmt/nagstamon/Makefile
@@ -15,7 +15,7 @@ COMMENT= Nagios status monitor for your desktop
LICENSE= GPLv2
RUN_DEPENDS= sox:audio/sox \
- ${PYTHON_PKGNAMEPREFIX}keyring>=1.3:security/py-keyring
+ ${PYTHON_PKGNAMEPREFIX}keyring>=1.3:security/py-keyring@${FLAVOR}
USES= cpe python:2
CPE_VENDOR= henri_wahl
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index aa120c40e13d..1bf28d2cf01c 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -76,8 +76,8 @@ TLS_CONFIGURE_ON= --with-security-modules=tsm --with-transports=TLSTCP,DTLSUDP
PYDISTUTILS_PKGNAME?= netsnmp-python
PYDISTUTILS_PKGVERSION?= 1.0a1
USES+= python
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/${PYTHON_PKGNAMEPREFIX}setuptools
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools
CONFIGURE_ARGS+=--with-python-modules
CONFIGURE_ENV+= PYTHONPROG="${PYTHON_CMD}"
MAKE_ENV+= PYDISTUTILS_INSTALLARGS="${PYDISTUTILS_INSTALLARGS}" STAGEDIR="${STAGEDIR}"
diff --git a/net-mgmt/onionlauncher/Makefile b/net-mgmt/onionlauncher/Makefile
index d7561f57233a..6577e86fac64 100644
--- a/net-mgmt/onionlauncher/Makefile
+++ b/net-mgmt/onionlauncher/Makefile
@@ -11,14 +11,14 @@ COMMENT= Launcher for Tor
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>=0.18:security/py-stem \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>=0.18:security/py-stem@${FLAVOR} \
tor:security/tor
USE_GITHUB= yes
GH_ACCOUNT= neelchauhan
GH_PROJECT= OnionLauncher
-USES= pyqt:5 python
+USES= pyqt:5 python:2.7
USE_PYTHON= autoplist distutils
USE_PYQT= core_run gui_run widgets_run
diff --git a/net-mgmt/py-adal/Makefile b/net-mgmt/py-adal/Makefile
index 94bd6ebc6c2b..426b17dfbdf3 100644
--- a/net-mgmt/py-adal/Makefile
+++ b/net-mgmt/py-adal/Makefile
@@ -12,10 +12,10 @@ COMMENT= Authentication ot Azure Active Directory for python apps
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography \
- ${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:www/py-pyjwt \
- ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:devel/py-dateutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:www/py-pyjwt@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
diff --git a/net-mgmt/py3-dnsdiag/Makefile b/net-mgmt/py-dnsdiag/Makefile
index 128466089e1f..228d0c3e22bd 100644
--- a/net-mgmt/py3-dnsdiag/Makefile
+++ b/net-mgmt/py-dnsdiag/Makefile
@@ -12,17 +12,10 @@ COMMENT= DNS Diagnostics and measurement tools (ping, traceroute)
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=1.15.0:dns/py-dnspython \
- ${PYTHON_PKGNAMEPREFIX}cymruwhois>=1.6:net/py-cymruwhois
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=1.15.0:dns/py-dnspython@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cymruwhois>=1.6:net/py-cymruwhois@${FLAVOR}
USES= python:3.3+
USE_PYTHON= autoplist distutils
-.include <bsd.port.pre.mk>
-
-.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
- ${PYTHON_VER} != ${PYTHON_DEFAULT}
-IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/py3-dnsdiag/distinfo b/net-mgmt/py-dnsdiag/distinfo
index 1567f90d7968..1567f90d7968 100644
--- a/net-mgmt/py3-dnsdiag/distinfo
+++ b/net-mgmt/py-dnsdiag/distinfo
diff --git a/net-mgmt/py3-dnsdiag/pkg-descr b/net-mgmt/py-dnsdiag/pkg-descr
index d5a60c2101f0..d5a60c2101f0 100644
--- a/net-mgmt/py3-dnsdiag/pkg-descr
+++ b/net-mgmt/py-dnsdiag/pkg-descr
diff --git a/net-mgmt/py-ipcalc/Makefile b/net-mgmt/py-ipcalc/Makefile
index d4440121747d..d11bf7e6b45f 100644
--- a/net-mgmt/py-ipcalc/Makefile
+++ b/net-mgmt/py-ipcalc/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Module to perform IP subnet calculations
USES= python
-USE_PYTHON= distutils
+USE_PYTHON= distutils autoplist
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/net-mgmt/py-ipcalc/pkg-plist b/net-mgmt/py-ipcalc/pkg-plist
deleted file mode 100644
index 6b5618f5aa70..000000000000
--- a/net-mgmt/py-ipcalc/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%PYTHON_SITELIBDIR%%/ipcalc.pyo
-%%PYTHON_SITELIBDIR%%/ipcalc.pyc
-%%PYTHON_SITELIBDIR%%/ipcalc.py
diff --git a/net-mgmt/py-msrest/Makefile b/net-mgmt/py-msrest/Makefile
index 4fcabda91c0f..1b09a866d0b0 100644
--- a/net-mgmt/py-msrest/Makefile
+++ b/net-mgmt/py-msrest/Makefile
@@ -12,10 +12,10 @@ COMMENT= AutoRest swagger generator Python client runtime
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi \
- ${PYTHON_PKGNAMEPREFIX}isodate>=0.5.4:devel/py-isodate \
- ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>0:www/py-requests-oauthlib \
- ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}isodate>=0.5.4:devel/py-isodate@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>0:www/py-requests-oauthlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
@@ -23,7 +23,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34@${FLAVOR}
.endif
.include <bsd.port.post.mk>
diff --git a/net-mgmt/py-msrestazure/Makefile b/net-mgmt/py-msrestazure/Makefile
index 998ccc8724b6..ee55757b7579 100644
--- a/net-mgmt/py-msrestazure/Makefile
+++ b/net-mgmt/py-msrestazure/Makefile
@@ -12,9 +12,9 @@ COMMENT= Azure-specific AutoRest swagger generator Python client runtime
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keyring>0:security/py-keyring \
- ${PYTHON_PKGNAMEPREFIX}msrest>0:net-mgmt/py-msrest \
- ${PYTHON_PKGNAMEPREFIX}adal>0:net-mgmt/py-adal
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keyring>0:security/py-keyring@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}msrest>0:net-mgmt/py-msrest@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}adal>0:net-mgmt/py-adal@${FLAVOR}
USES= python zip
USE_PYTHON= autoplist distutils
diff --git a/net-mgmt/py-pynsca/Makefile b/net-mgmt/py-pynsca/Makefile
index 2e027b838126..a7f9bf571c48 100644
--- a/net-mgmt/py-pynsca/Makefile
+++ b/net-mgmt/py-pynsca/Makefile
@@ -14,15 +14,15 @@ LICENSE= MPL11
OPTIONS_DEFINE= AES 3DES
AES_DESC= Provide AES encryption
-AES_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}mcrypt>=0:security/py-mcrypt
+AES_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}mcrypt>=0:security/py-mcrypt@${FLAVOR}
3DES_DESC= Provide 3DES encryption
-3DES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto
+3DES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto@${FLAVOR}
OPTIONS_DEFAULT=AES 3DES
NO_ARCH= yes
-USES= python
+USES= python:2.7
USE_PYTHON= autoplist distutils concurrent
.include <bsd.port.mk>
diff --git a/net-mgmt/py-pysmi/Makefile b/net-mgmt/py-pysmi/Makefile
index ee877c27a004..ccacfd33c5a3 100644
--- a/net-mgmt/py-pysmi/Makefile
+++ b/net-mgmt/py-pysmi/Makefile
@@ -13,7 +13,7 @@ COMMENT= SNMP/SMI MIB parsing in Python
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${FLAVOR}
NO_ARCH= yes
USES= python shebangfix
diff --git a/net-mgmt/py-pyzabbix/Makefile b/net-mgmt/py-pyzabbix/Makefile
index 39a09b572450..1f087ab927ca 100644
--- a/net-mgmt/py-pyzabbix/Makefile
+++ b/net-mgmt/py-pyzabbix/Makefile
@@ -12,7 +12,7 @@ COMMENT= Zabbix API Python Library
LICENSE= LGPL21
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.0:www/py-requests
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.0:www/py-requests@${FLAVOR}
USES= python:2.7
USE_PYTHON= distutils autoplist
diff --git a/net-mgmt/py-snmp4-apps/Makefile b/net-mgmt/py-snmp4-apps/Makefile
index 06325104906c..5ae0661227e3 100644
--- a/net-mgmt/py-snmp4-apps/Makefile
+++ b/net-mgmt/py-snmp4-apps/Makefile
@@ -14,7 +14,7 @@ COMMENT= Command line utilities for pysnmp4
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4>=4.2.3:net-mgmt/py-snmp4
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4>=4.2.3:net-mgmt/py-snmp4@${FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
diff --git a/net-mgmt/py-snmp4-mibs/Makefile b/net-mgmt/py-snmp4-mibs/Makefile
index 5af9f7fffc29..df70f8e381e4 100644
--- a/net-mgmt/py-snmp4-mibs/Makefile
+++ b/net-mgmt/py-snmp4-mibs/Makefile
@@ -15,7 +15,7 @@ COMMENT= Additional python MIB files for pysnmp4 and friends
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4>=4.2.3:net-mgmt/py-snmp4
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4>=4.2.3:net-mgmt/py-snmp4@${FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
diff --git a/net-mgmt/py-snmp4/Makefile b/net-mgmt/py-snmp4/Makefile
index 504e3dd20fd6..c1248cc164fb 100644
--- a/net-mgmt/py-snmp4/Makefile
+++ b/net-mgmt/py-snmp4/Makefile
@@ -15,8 +15,8 @@ COMMENT= SNMP framework for Python
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.2:devel/py-pyasn1 \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.4.1:security/py-pycrypto
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.2:devel/py-pyasn1@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.4.1:security/py-pycrypto@${FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
diff --git a/net-mgmt/seafile-client/Makefile b/net-mgmt/seafile-client/Makefile
index ff8d12f16d99..ee08827e3cb0 100644
--- a/net-mgmt/seafile-client/Makefile
+++ b/net-mgmt/seafile-client/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
libevent.so:devel/libevent \
libuuid.so:misc/e2fsprogs-libuuid \
libjansson.so:devel/jansson
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${PY_FLAVOR} \
bash:shells/bash
USES= autoreconf iconv libarchive libtool localbase mysql \
diff --git a/net-mgmt/seafile-server/Makefile b/net-mgmt/seafile-server/Makefile
index 9568b568230b..269174ccd8c6 100644
--- a/net-mgmt/seafile-server/Makefile
+++ b/net-mgmt/seafile-server/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
libevent.so:devel/libevent \
libuuid.so:misc/e2fsprogs-libuuid \
libjansson.so:devel/jansson
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${PY_FLAVOR} \
bash:shells/bash
CONFLICTS= seafile-[0-9]*
diff --git a/net-mgmt/tornova/Makefile b/net-mgmt/tornova/Makefile
index 1eeba8c28c76..18534dbfc37b 100644
--- a/net-mgmt/tornova/Makefile
+++ b/net-mgmt/tornova/Makefile
@@ -11,7 +11,7 @@ COMMENT= Frontend for Tor
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>=0.18:security/py-stem \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>=0.18:security/py-stem@${FLAVOR} \
tor:security/tor
USE_GITHUB= yes
diff --git a/net-mgmt/wmi-client/Makefile b/net-mgmt/wmi-client/Makefile
index 7abfd8ae2786..6fdbe1f3105f 100644
--- a/net-mgmt/wmi-client/Makefile
+++ b/net-mgmt/wmi-client/Makefile
@@ -29,7 +29,7 @@ PROGS= bin/wmic bin/winexe
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USES+= python
+USES+= python:2.7
MAKE_ARGS+= PYTHON="${PYTHON_CMD}" PY_LIBDIR="${PYTHONPREFIX_SITELIBDIR}"
PLIST_SUB+= PYTHON=""
.else