aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/autoscan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/autoscan/Makefile')
-rw-r--r--net-p2p/autoscan/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-p2p/autoscan/Makefile b/net-p2p/autoscan/Makefile
new file mode 100644
index 000000000000..c8b91e1af522
--- /dev/null
+++ b/net-p2p/autoscan/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= autoscan
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.0
+CATEGORIES= net-p2p linux
+MASTER_SITES= https://github.com/Cloudbox/autoscan/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/
+DISTNAME= ${PORTNAME}_${DISTVERSIONPREFIX}${DISTVERSION}_linux_amd64
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= michiel@vanbaak.eu
+COMMENT= Scan Plex library on webhook triggers
+
+LICENSE= MIT
+
+ONLY_FOR_ARCHS= amd64
+
+USES= linux
+USE_RC_SUBR= autoscan
+
+CONFLICTS_INSTALL= autoconf-wrapper
+
+NO_BUILD= yes
+SUB_LIST= GROUPS=${GROUPS} \
+ USERS=${USERS}
+
+NO_WRKSUBDIR= yes
+
+USERS= autoscan
+GROUPS= autoscan
+
+PLIST_FILES= bin/autoscan
+
+do-install:
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>