aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/autoscan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/autoscan/Makefile')
-rw-r--r--net-p2p/autoscan/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/net-p2p/autoscan/Makefile b/net-p2p/autoscan/Makefile
index c8b91e1af522..c64d1d174a86 100644
--- a/net-p2p/autoscan/Makefile
+++ b/net-p2p/autoscan/Makefile
@@ -1,36 +1,29 @@
PORTNAME= autoscan
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.0
-CATEGORIES= net-p2p linux
-MASTER_SITES= https://github.com/Cloudbox/autoscan/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/
-DISTNAME= ${PORTNAME}_${DISTVERSIONPREFIX}${DISTVERSION}_linux_amd64
-EXTRACT_SUFX=
-EXTRACT_ONLY=
+DISTVERSION= 1.3.0
+CATEGORIES= net-p2p
MAINTAINER= michiel@vanbaak.eu
COMMENT= Scan Plex library on webhook triggers
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= amd64
-
-USES= linux
+USES= go:modules
USE_RC_SUBR= autoscan
+GO_MODULE= github.com/cloudbox/autoscan
+GO_TARGET= ./cmd/autoscan
+GO_BUILDFLAGS+= -ldflags="-s -w -X main.Version=${DISTVERSION}"
+
CONFLICTS_INSTALL= autoconf-wrapper
-NO_BUILD= yes
SUB_LIST= GROUPS=${GROUPS} \
USERS=${USERS}
-NO_WRKSUBDIR= yes
-
USERS= autoscan
GROUPS= autoscan
PLIST_FILES= bin/autoscan
-do-install:
- ${INSTALL_PROGRAM} ${DISTDIR}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
.include <bsd.port.mk>