aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/p5-Net-BitTorrent-File/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/p5-Net-BitTorrent-File/Makefile')
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/net-p2p/p5-Net-BitTorrent-File/Makefile b/net-p2p/p5-Net-BitTorrent-File/Makefile
index 44891551fb44..eb227ab01b39 100644
--- a/net-p2p/p5-Net-BitTorrent-File/Makefile
+++ b/net-p2p/p5-Net-BitTorrent-File/Makefile
@@ -16,9 +16,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-fix
MAINTAINER= mor@WhiteLuna.com
COMMENT= Perl5 module for handles loading and saveing of .torrent file
-BUILD_DEPENDS= ${SITE_PERL}/Convert/Bencode.pm:${PORTSDIR}/converters/p5-Convert-Bencode \
+RUN_DEPENDS= ${SITE_PERL}/Convert/Bencode.pm:${PORTSDIR}/converters/p5-Convert-Bencode \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
WRKSRC= ${WRKDIR}/${DISTNAME:S/-fix//}
@@ -26,4 +27,15 @@ PERL_CONFIGURE= yes
MAN3= Net::BitTorrent::File.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${REINPLACE_CMD} -e '/warnings/d' ${WRKSRC}/lib/Net/BitTorrent/File.pm
+ ${FIND} ${WRKSRC} -name "*.bak" -delete
+
+post-configure:
+ ${PERL} -pi -e 's/-I\S+PERL\S+ //g if m{PERL_DL_NONLAZY}' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>