aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrent-file-editor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/torrent-file-editor/Makefile')
-rw-r--r--net-p2p/torrent-file-editor/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index 59948eb41bca..189567600bfb 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -41,4 +41,9 @@ DEPRECATED= Qt4 has been EOL since december 2015
EXPIRATION_DATE= 2019-03-15
.endif
+post-patch:
+# Avoid conflict with C++20 <version> by adding .txt suffix
+ @${REINPLACE_CMD} -i .c++20 '/file/s/version/&.txt/' \
+ ${WRKSRC}/Version.cmake ${WRKSRC}/Dmg.cmake
+
.include <bsd.port.mk>