aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/verlihub/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/verlihub/Makefile')
-rw-r--r--net-p2p/verlihub/Makefile56
1 files changed, 0 insertions, 56 deletions
diff --git a/net-p2p/verlihub/Makefile b/net-p2p/verlihub/Makefile
deleted file mode 100644
index 3a1d1470d622..000000000000
--- a/net-p2p/verlihub/Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
-# New ports collection makefile for: verlihub
-# Date created: 2 April 2004
-# Whom: Hurbold
-#
-# $FreeBSD$
-#
-
-PORTNAME= verlihub
-PORTVERSION= 0.9.8.a
-PORTEPOCH= 1
-CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= verlihub
-DISTNAME= verlihub-0.9.8a
-
-MAINTAINER= hurbold@yahoo.com
-COMMENT= Verlihub Linux/Unix Direct Connect Hub Software
-
-LIB_DEPENDS= GeoIP.4:${PORTSDIR}/net/GeoIP \
- pcre.0:${PORTSDIR}/devel/pcre
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
-
-USE_MYSQL= yes
-USE_PERL5= yes
-USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 15
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PORTDOCS= configuring.txt help.sql using.txt features.html help.html params.php verlihub.html
-
-post-patch:
- @${CAT} ${PKGDIR}/pkg-message | ${SED} 's|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}
-.endfor
-.endif
-
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502010
-USE_GCC= 3.4
-.endif
-
-.if ${OSVERSION} >= 502126
-BROKEN= Does not compile with gcc 3.4
-.endif
-
-.include <bsd.port.post.mk>