aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/xmule/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/xmule/Makefile')
-rw-r--r--net-p2p/xmule/Makefile86
1 files changed, 0 insertions, 86 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
deleted file mode 100644
index 8b0f2caa1425..000000000000
--- a/net-p2p/xmule/Makefile
+++ /dev/null
@@ -1,86 +0,0 @@
-# New ports collection makefile for: xmule
-# Date created: Tue Mar 11 05:06:20 UTC 2003
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= xmule
-PORTVERSION= 1.8.2
-CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= xmule
-
-MAINTAINER= lioux@FreeBSD.org
-COMMENT= Port of eMule eDonkey P2P client using wxWindows class library
-
-LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
- wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
-RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
-
-USE_GETTEXT= yes
-USE_X_PREFIX= yes
-USE_BZIP2= yes
-USE_GNOME= gnomehier \
- gnomehack \
- gnomeprefix
-USE_REINPLACE= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-included-gettext \
- --with-gtk-prefix=${X11BASE} \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-libintl-prefix=${LOCALBASE} \
- --enable-debug \
- --with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
-
-# for debugging purposes
-STRIP=
-
-WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
-
-FILES_ATOLL_PATCH= src/Preferences.cpp \
- src/otherfunctions.cpp
-
-post-patch:
-# it works for FreeBSD as well
- @${REINPLACE_CMD} -E \
- -e 's|(Linux)|FreeBSD/\1|' \
- ${WRKSRC}/src/*.cpp
-# update documentation with correct prefix
- @${REINPLACE_CMD} -E \
- -e 's|/usr/X11R6/(bin/${PORTNAME}-ed2k-handler)|${PREFIX}/\1|' \
- ${WRKSRC}/ED2K-Links.HOWTO
-# use BSD_INSTALL_* macros
- @${REINPLACE_CMD} -E \
- -e 's|cp -f|${INSTALL_DATA}|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -E \
- -e 's|cp -p|${INSTALL_DATA}|' \
- ${WRKSRC}/po/Makefile.in.in
-# use correct FreeBSD atoll() prototype
-.for file in ${FILES_ATOLL_PATCH}
- @${REINPLACE_CMD} -E \
- -e 's|atoll[[:space:]]*\([[:space:]]*char|atoll(const char|' \
- ${WRKSRC}/${file}
-.endfor
-
-pre-configure:
- @${FIND} ${WRKSRC} -type f -name "Makefile.in" | \
- ${XARGS} -x -n 10 \
- ${REINPLACE_CMD} -E \
- -e 's!^(AUTOCONF|AUTOHEADER|AUTOMAKE|ACLOCAL).*$$!\1=${TRUE}!'
-
-post-install:
-# install xmule binary
- @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
- ${PREFIX}/bin
-# do not install a generic named ed2k binary
-# install it under a more specific name
- @${INSTALL_PROGRAM} ${WRKSRC}/src/ed2k \
- ${PREFIX}/bin/${PORTNAME}-ed2k-handler
-
-.include <bsd.port.mk>