aboutsummaryrefslogtreecommitdiff
path: root/net/aoe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/aoe/Makefile')
-rw-r--r--net/aoe/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index fa62a1acafcc..4a1e523107f2 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -1,32 +1,29 @@
-# Created by: Stacey D. Son <sds@son.org>
-
PORTNAME= aoe
PORTVERSION= 1.2.0
-PORTREVISION= 2
+PORTREVISION= 5
CATEGORIES= net
-MASTER_SITES= http://www.son.org/download/
+MASTER_SITES= https://people.freebsd.org/~sson/aoe/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
-MAINTAINER= fjoe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= FreeBSD driver for ATA over Ethernet (AoE)
+WWW= https://web.archive.org/web/20120420082041/http://www.coraid.com/support/freebsd/
+
+LICENSE= BSD2CLAUSE
-BROKEN_aarch64= fails to compile: redefinition of frame
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
-BROKEN_armv7= fails to compile: redefinition of frame
-BROKEN_sparc64= fails to compile: redefinition of frame
-BROKEN_FreeBSD_12= no member named 'tqh_first' in 'struct ifnethead'
-BROKEN_FreeBSD_13= no member named 'tqh_first' in 'struct ifnethead'
-BROKEN_FreeBSD_14= no member named 'tqh_first' in 'struct ifnethead'
+BROKEN_FreeBSD_13= crashes dereferencing vnet_entry_ifnet
+BROKEN_FreeBSD_14= crashes dereferencing vnet_entry_ifnet
-USES= kmod
+USES= kmod uidfix
+USE_RC_SUBR= aoe
WRKSRC= ${WRKDIR}/dev/aoe
-KMODDIR= ${PREFIX}/lib/aoe
-USE_RC_SUBR= aoe
+PLIST_FILES= share/man/man4/aoe.4.gz \
+ ${KMODDIR}/aoe.ko
-do-install:
- ${INSTALL_KLD} ${WRKSRC}/aoe.ko ${STAGEDIR}${PREFIX}/lib/aoe
- ${INSTALL_MAN} ${WRKDIR}/aoe.4 ${STAGEDIR}${PREFIX}/man/man4/
+post-install:
+ ${INSTALL_MAN} ${WRKDIR}/aoe.4 ${STAGEDIR}${PREFIX}/share/man/man4/
.include <bsd.port.mk>