aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk16/files')
-rw-r--r--net/asterisk16/files/asterisk.in86
-rw-r--r--net/asterisk16/files/patch-Makefile122
-rw-r--r--net/asterisk16/files/patch-agi_Makefile13
-rw-r--r--net/asterisk16/files/patch-build__tools_make__xml__documentation11
-rw-r--r--net/asterisk16/files/patch-channels_chan__dahdi.c33
-rw-r--r--net/asterisk16/files/patch-channels_sip_include_sip.h11
-rw-r--r--net/asterisk16/files/patch-configure79
-rw-r--r--net/asterisk16/files/patch-contrib_Makefile23
-rw-r--r--net/asterisk16/files/patch-main_Makefile16
-rw-r--r--net/asterisk16/files/patch-main_lock.c12
-rw-r--r--net/asterisk16/files/patch-main_term.c10
-rw-r--r--net/asterisk16/files/patch-menuselect_configure11
-rw-r--r--net/asterisk16/files/patch-third-party_pjproject_Makefile30
-rw-r--r--net/asterisk16/files/patch-third-party_pjproject_Makefile.rules20
14 files changed, 0 insertions, 477 deletions
diff --git a/net/asterisk16/files/asterisk.in b/net/asterisk16/files/asterisk.in
deleted file mode 100644
index 5fab82c5700e..000000000000
--- a/net/asterisk16/files/asterisk.in
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# PROVIDE: asterisk
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf to enable asterisk:
-#
-# asterisk_enable (bool): Set it to "YES" to enable asterisk
-# Default is "NO"
-# asterisk_user (string): User asterisk runs as
-# Default is %%ASTERISK_USER%%
-# asterisk_group (string): Group asterisk runs as
-# Default is %%ASTERISK_GROUP%%
-# asterisk_args (string): Extra argumeents to pass to asterisk at startup
-# Default is "-n"
-# asterisk_pidfile (string): Location of the asterisk pid file
-# Default is /var/run/asterisk/asterisk.pid
-# asterisk_stopsleep (int): Number of seconds to sleep before sending stop command
-# Default is 0, which disables it
-# asterisk_umask (string): File creation mode mask to run asterisk with
-#
-
-. /etc/rc.subr
-
-name=asterisk
-rcvar=asterisk_enable
-desc="Asterisk PBX server"
-
-load_rc_config $name
-
-: ${asterisk_enable:=NO}
-: ${asterisk_user:=%%ASTERISK_USER%%}
-: ${asterisk_group:=%%ASTERISK_GROUP%%}
-: ${asterisk_args=-n}
-: ${asterisk_pidfile:=/var/run/asterisk/asterisk.pid}
-: ${asterisk_stopsleep:=0}
-
-extra_commands=reload
-
-start_precmd=asterisk_precmd
-stop_cmd=asterisk_stop
-reload_cmd=asterisk_reload
-
-pidfile="${asterisk_pidfile}"
-
-command="%%PREFIX%%/sbin/asterisk"
-command_args="${asterisk_args} -F -U ${asterisk_user}"
-
-asterisk_precmd()
-{
- local rundir=${asterisk_pidfile%/*}
- if [ ! -d $rundir ] ; then
- install -d -m 0750 -o "${asterisk_user}" -g "${asterisk_group}" "$rundir"
- fi
- if [ -n "${asterisk_umask}" ]; then
- umask ${asterisk_umask}
- fi
-}
-
-asterisk_stop()
-{
- if [ -z "$rc_pid" ]; then
- [ -n "$rc_fast" ] && return 0
- _run_rc_notrunning
- return 1
- fi
- echo 'Stopping asterisk.'
- if [ ${asterisk_stopsleep} -gt 0 ]; then
- sleep ${asterisk_stopsleep}
- fi
- $command -rx 'core stop now'
- wait_for_pids $rc_pid
-}
-
-asterisk_reload()
-{
- if [ -z "$rc_pid" ]; then
- _run_rc_notrunning
- return 1
- fi
- echo 'Reloading asterisk.'
- $command -rx 'reload'
-}
-
-run_rc_command "$1"
diff --git a/net/asterisk16/files/patch-Makefile b/net/asterisk16/files/patch-Makefile
deleted file mode 100644
index 04b5fd6d9894..000000000000
--- a/net/asterisk16/files/patch-Makefile
+++ /dev/null
@@ -1,122 +0,0 @@
---- Makefile.orig 2020-11-12 12:03:45 UTC
-+++ Makefile
-@@ -138,7 +138,7 @@ ASTTOPDIR:=$(subst $(space),\$(space),$(CURDIR))
- OVERWRITE=y
-
- # Include debug and macro symbols in the executables (-g) and profiling info (-pg)
--DEBUG=-g3
-+#DEBUG=-g3
-
- # Asterisk.conf is located in ASTETCDIR or by using the -C flag
- # when starting Asterisk
-@@ -162,7 +162,7 @@ LINKER_SYMBOL_PREFIX=
- #_ASTCFLAGS+=-DOLD_DSP_ROUTINES
-
- # Default install directory for DAHDI hooks.
--DAHDI_UDEV_HOOK_DIR = /usr/share/dahdi/span_config.d
-+#DAHDI_UDEV_HOOK_DIR = /usr/share/dahdi/span_config.d
-
- # If the file .asterisk.makeopts is present in your home directory, you can
- # include all of your favorite menuselect options so that every time you download
-@@ -222,7 +222,7 @@ endif
-
- ifeq ($(OSARCH),FreeBSD)
- # -V is understood by BSD Make, not by GNU make.
-- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
-+ BSDVERSION=$(OSVERSION)
- _ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
- endif
-
-@@ -466,8 +466,12 @@ endif
- $(INSTALL) -m 644 $$n "$(DESTDIR)$(ASTDATADIR)/static-http/docs" ; \
- done \
- fi
-+ if [ ! -d $(DESTDIR)$(DOCSDIR)/images ]; then \
-+ $(MKDIR) $(DESTDIR)$(DOCSDIR)/images; \
-+ fi
-+
- for x in images/*.jpg; do \
-- $(INSTALL) -m 644 $$x "$(DESTDIR)$(ASTDATADIR)/images" ; \
-+ $(INSTALL) -m 644 $$x "$(DESTDIR)$(DOCSDIR)/images" ; \
- done
- $(MAKE) -C sounds install
- find rest-api -name "*.json" | while read x; do \
-@@ -565,7 +569,7 @@ INSTALLDIRS="$(ASTLIBDIR)" "$(ASTMODDIR)" "$(ASTSBINDI
- "$(ASTDATADIR)/firmware/iax" "$(ASTDATADIR)/images" "$(ASTDATADIR)/keys" \
- "$(ASTDATADIR)/phoneprov" "$(ASTDATADIR)/rest-api" "$(ASTDATADIR)/static-http" \
- "$(ASTDATADIR)/sounds" "$(ASTDATADIR)/moh" "$(ASTMANDIR)/man8" "$(AGI_DIR)" "$(ASTDBDIR)" \
-- "$(ASTDATADIR)/third-party" "${ASTDATADIR}/keys/stir_shaken"
-+ "$(ASTDATADIR)/third-party" "${ASTDATADIR}/keys/stir_shaken" "$(ASTSPOOLDIR)/outgoing"
-
- installdirs:
- @for i in $(INSTALLDIRS); do \
-@@ -598,10 +602,10 @@ endif
- if [ -f contrib/firmware/iax/iaxy.bin ] ; then \
- $(INSTALL) -m 644 contrib/firmware/iax/iaxy.bin "$(DESTDIR)$(ASTDATADIR)/firmware/iax/iaxy.bin"; \
- fi
--ifeq ($(HAVE_DAHDI),1)
-- $(INSTALL) -d $(DESTDIR)/$(DAHDI_UDEV_HOOK_DIR)
-- $(INSTALL) -m 644 contrib/scripts/dahdi_span_config_hook $(DESTDIR)$(DAHDI_UDEV_HOOK_DIR)/40-asterisk
--endif
-+#ifeq ($(HAVE_DAHDI),1)
-+# $(INSTALL) -d $(DESTDIR)/$(DAHDI_UDEV_HOOK_DIR)
-+# $(INSTALL) -m 644 contrib/scripts/dahdi_span_config_hook $(DESTDIR)$(DAHDI_UDEV_HOOK_DIR)/40-asterisk
-+#endif
-
- $(SUBDIRS_INSTALL):
- +@DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" ASTDATADIR="$(ASTDATADIR)" $(SUBMAKE) -C $(@:-install=) install
-@@ -716,7 +720,7 @@ ifneq ($(filter ~%,$(DESTDIR)),)
- @exit 1
- endif
-
--install: badshell bininstall datafiles
-+install: badshell bininstall datafiles samples
- @if [ -x /usr/sbin/asterisk-post-install ]; then \
- /usr/sbin/asterisk-post-install "$(DESTDIR)" . ; \
- fi
-@@ -761,23 +765,10 @@ upgrade: bininstall
- # (2) the extension to strip off
- define INSTALL_CONFIGS
- @for x in $(1)/*$(2); do \
-- dst="$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x $(2)`"; \
-- if [ -f "$${dst}" ]; then \
-- if [ "$(OVERWRITE)" = "y" ]; then \
-- if cmp -s "$${dst}" "$$x" ; then \
-- echo "Config file $$x is unchanged"; \
-- continue; \
-- fi ; \
-- mv -f "$${dst}" "$${dst}.old" ; \
-- else \
-- echo "Skipping config file $$x"; \
-- continue; \
-- fi ;\
-- fi ; \
- echo "Installing file $$x"; \
-- $(INSTALL) -m 644 "$$x" "$${dst}" ;\
-+ $(INSTALL) -m 644 $$x $(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x .sample`.sample ; \
- done ; \
-- if [ "$(OVERWRITE)" = "y" ]; then \
-+ if true; then \
- echo "Updating asterisk.conf" ; \
- sed -e 's|^astetcdir.*$$|astetcdir => $(ASTETCDIR)|' \
- -e 's|^astmoddir.*$$|astmoddir => $(ASTMODDIR)|' \
-@@ -790,8 +781,8 @@ define INSTALL_CONFIGS
- -e 's|^astrundir.*$$|astrundir => $(ASTVARRUNDIR)|' \
- -e 's|^astlogdir.*$$|astlogdir => $(ASTLOGDIR)|' \
- -e 's|^astsbindir.*$$|astsbindir => $(ASTSBINDIR)|' \
-- "$(DESTDIR)$(ASTCONFPATH)" > "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
-- $(INSTALL) -m 644 "$(DESTDIR)$(ASTCONFPATH).tmp" "$(DESTDIR)$(ASTCONFPATH)" ; \
-+ "$(DESTDIR)$(ASTCONFPATH).sample" > "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
-+ $(INSTALL) -m 644 "$(DESTDIR)$(ASTCONFPATH).tmp" "$(DESTDIR)$(ASTCONFPATH).sample" ; \
- rm -f "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
- fi
- endef
-@@ -825,7 +816,7 @@ adsi:
- else \
- echo "Installing $$x" ; \
- fi ; \
-- $(INSTALL) -m 644 "$$x" "$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x`" ; \
-+ $(INSTALL) -m 644 $$x $(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x`.sample ; \
- done
-
- samples: adsi
diff --git a/net/asterisk16/files/patch-agi_Makefile b/net/asterisk16/files/patch-agi_Makefile
deleted file mode 100644
index 019ad10e1ef9..000000000000
--- a/net/asterisk16/files/patch-agi_Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- agi/Makefile.orig 2020-07-09 15:39:17 UTC
-+++ agi/Makefile
-@@ -16,7 +16,9 @@ ASTTOPDIR?=..
-
- .PHONY: clean all uninstall
-
--AGIS=$(MENUSELECT_AGIS)
-+AGIS_BIN=eagi-test eagi-sphinx-test
-+AGIS_SCR=agi-test.agi jukebox.agi
-+AGIS=$(AGIS_SCR) $(AGIS_BIN)
-
- ifeq ($(OSARCH),SunOS)
- LIBS+=-lsocket -lnsl
diff --git a/net/asterisk16/files/patch-build__tools_make__xml__documentation b/net/asterisk16/files/patch-build__tools_make__xml__documentation
deleted file mode 100644
index 9b6dec995449..000000000000
--- a/net/asterisk16/files/patch-build__tools_make__xml__documentation
+++ /dev/null
@@ -1,11 +0,0 @@
---- build_tools/make_xml_documentation.orig 2022-03-17 15:34:42 UTC
-+++ build_tools/make_xml_documentation
-@@ -228,7 +228,7 @@ for subdir in ${mod_subdirs} ; do
- ${XMLSTARLET} val -e -d "${source_tree}/doc/appdocsxml.dtd" "${i}" || { echo "" ; exit 1 ; }
- fi
- fi
-- ${SED} -r "/^\s*(<[?]xml|<.DOCTYPE|<.?docs)/d" "${i}" >> "${output_file}"
-+ ${SED} -r "/^[[:space:]]*(<[?]xml|<.DOCTYPE|<.?docs)/d" "${i}" >> "${output_file}"
- done
- done
- echo "</docs>" >> "${output_file}"
diff --git a/net/asterisk16/files/patch-channels_chan__dahdi.c b/net/asterisk16/files/patch-channels_chan__dahdi.c
deleted file mode 100644
index cc294c5ba840..000000000000
--- a/net/asterisk16/files/patch-channels_chan__dahdi.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- channels/chan_dahdi.c.orig 2020-07-09 15:39:17 UTC
-+++ channels/chan_dahdi.c
-@@ -4649,6 +4649,8 @@ void dahdi_ec_enable(struct dahdi_pvt *p)
- return;
- }
- if (p->echocancel.head.tap_length) {
-+ struct dahdi_echocanparams *pecp;
-+
- #if defined(HAVE_PRI) || defined(HAVE_SS7)
- switch (p->sig) {
- #if defined(HAVE_PRI)
-@@ -4679,7 +4681,9 @@ void dahdi_ec_enable(struct dahdi_pvt *p)
- break;
- }
- #endif /* defined(HAVE_PRI) || defined(HAVE_SS7) */
-- res = ioctl(p->subs[SUB_REAL].dfd, DAHDI_ECHOCANCEL_PARAMS, &p->echocancel);
-+
-+ pecp = &p->echocancel.head;
-+ res = ioctl(p->subs[SUB_REAL].dfd, DAHDI_ECHOCANCEL_PARAMS, &pecp);
- if (res) {
- ast_log(LOG_WARNING, "Unable to enable echo cancellation on channel %d (%s)\n", p->channel, strerror(errno));
- } else {
-@@ -4713,8 +4717,9 @@ void dahdi_ec_disable(struct dahdi_pvt *p)
-
- if (p->echocanon) {
- struct dahdi_echocanparams ecp = { .tap_length = 0 };
-+ struct dahdi_echocanparams *pecp = &ecp;
-
-- res = ioctl(p->subs[SUB_REAL].dfd, DAHDI_ECHOCANCEL_PARAMS, &ecp);
-+ res = ioctl(p->subs[SUB_REAL].dfd, DAHDI_ECHOCANCEL_PARAMS, &pecp);
-
- if (res)
- ast_log(LOG_WARNING, "Unable to disable echo cancellation on channel %d: %s\n", p->channel, strerror(errno));
diff --git a/net/asterisk16/files/patch-channels_sip_include_sip.h b/net/asterisk16/files/patch-channels_sip_include_sip.h
deleted file mode 100644
index d1668bf70598..000000000000
--- a/net/asterisk16/files/patch-channels_sip_include_sip.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- channels/sip/include/sip.h.orig 2020-07-09 15:39:17 UTC
-+++ channels/sip/include/sip.h
-@@ -192,7 +192,7 @@
- #define DEFAULT_MOHINTERPRET "default" /*!< The default music class */
- #define DEFAULT_MOHSUGGEST ""
- #define DEFAULT_VMEXTEN "asterisk" /*!< Default voicemail extension */
--#define DEFAULT_CALLERID "asterisk" /*!< Default caller ID */
-+#define DEFAULT_CALLERID "Unknown" /*!< Default caller ID */
- #define DEFAULT_MWI_FROM ""
- #define DEFAULT_NOTIFYMIME "application/simple-message-summary"
- #define DEFAULT_ALLOWGUEST TRUE
diff --git a/net/asterisk16/files/patch-configure b/net/asterisk16/files/patch-configure
deleted file mode 100644
index 035ad3df2fe0..000000000000
--- a/net/asterisk16/files/patch-configure
+++ /dev/null
@@ -1,79 +0,0 @@
---- configure.orig 2022-05-05 14:21:18 UTC
-+++ configure
-@@ -5148,8 +5148,6 @@ case "${host_os}" in
- ;;
- dragonfly*|freebsd*)
- ac_default_prefix=/usr/local
-- CPPFLAGS=-I/usr/local/include
-- LDFLAGS=-L/usr/local/lib
- ;;
- openbsd*)
- ac_default_prefix=/usr/local
-@@ -22951,6 +22949,8 @@ printf %s "checking for getifaddrs() support... " >&6;
-
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-+ #include <sys/types.h>
-+ #include <sys/socket.h>
- #include <ifaddrs.h>
- int
- main (void)
-@@ -32266,6 +32266,8 @@ for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
-
- for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
-
-+vernodot=`echo ${ver} | sed 's/\.//'`
-+
- if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no"; then
- pbxlibdir=""
- # if --with-LUA=DIR has been specified, use it.
-@@ -32280,14 +32282,14 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
- ast_ext_lib_check_save_CFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} "
- as_ac_Lib=`printf "%s\n" "ac_cv_lib_lua${ver}""_luaL_newstate" | $as_tr_sh`
--{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua${ver}" >&5
--printf %s "checking for luaL_newstate in -llua${ver}... " >&6; }
-+{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-${ver}" >&5
-+printf %s "checking for luaL_newstate in -llua-${ver}... " >&6; }
- if eval test \${$as_ac_Lib+y}
- then :
- printf %s "(cached) " >&6
- else $as_nop
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-llua${ver} ${pbxlibdir} -lm $LIBS"
-+LIBS="-llua-${ver} ${pbxlibdir} -lm $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-@@ -32328,7 +32330,7 @@ fi
-
- # now check for the header.
- if test "${AST_LUA_FOUND}" = "yes"; then
-- LUA_LIB="${pbxlibdir} -llua${ver} -lm"
-+ LUA_LIB="${pbxlibdir} -llua-${ver} -lm"
- # if --with-LUA=DIR has been specified, use it.
- if test "x${LUA_DIR}" != "x"; then
- LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -32338,8 +32340,8 @@ fi
- # check for the header
- ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
- CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
-- as_ac_Header=`printf "%s\n" "ac_cv_header_lua${ver}/lua.h" | $as_tr_sh`
--ac_fn_c_check_header_compile "$LINENO" "lua${ver}/lua.h" "$as_ac_Header" "$ac_includes_default"
-+ as_ac_Header=`printf "%s\n" "ac_cv_header_lua${vernodot}/lua.h" | $as_tr_sh`
-+ac_fn_c_check_header_compile "$LINENO" "lua${vernodot}/lua.h" "$as_ac_Header" "$ac_includes_default"
- if eval test \"x\$"$as_ac_Header"\" = x"yes"
- then :
- LUA_HEADER_FOUND=1
-@@ -32366,9 +32368,9 @@ fi
-
- if test "x${PBX_LUA}" = "x1" ; then
- if test x"${LUA_DIR}" = x; then
-- LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua${ver}"
-+ LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua${vernodot}"
- else
-- LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua${ver}"
-+ LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua${vernodot}"
- fi
- break;
- fi
diff --git a/net/asterisk16/files/patch-contrib_Makefile b/net/asterisk16/files/patch-contrib_Makefile
deleted file mode 100644
index dc38a639baad..000000000000
--- a/net/asterisk16/files/patch-contrib_Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- contrib/Makefile.orig 2020-07-09 15:39:17 UTC
-+++ contrib/Makefile
-@@ -24,14 +24,14 @@ install:
- $(INSTALL) -m 755 scripts/ast_logescalator "$(DESTDIR)$(ASTDATADIR)/scripts/ast_logescalator"
- $(INSTALL) -m 755 scripts/ast_loggrabber "$(DESTDIR)$(ASTDATADIR)/scripts/ast_loggrabber"
- $(INSTALL) -m 755 scripts/ast_coredumper "$(DESTDIR)$(ASTDATADIR)/scripts/ast_coredumper"
-- $(INSTALL) -m 755 scripts/refcounter.py "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
-- $(INSTALL) -m 755 scripts/refstats.py "$(DESTDIR)$(ASTDATADIR)/scripts/refstats.py"
-- $(INSTALL) -m 755 scripts/reflocks.py "$(DESTDIR)$(ASTDATADIR)/scripts/reflocks.py"
-+# $(INSTALL) -m 755 scripts/refcounter.py "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
-+# $(INSTALL) -m 755 scripts/refstats.py "$(DESTDIR)$(ASTDATADIR)/scripts/refstats.py"
-+# $(INSTALL) -m 755 scripts/reflocks.py "$(DESTDIR)$(ASTDATADIR)/scripts/reflocks.py"
-
- uninstall:
- -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/ast_logescalator"
- -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/ast_loggrabber"
- -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/ast_coredumper"
-- -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
-- -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/refstats.py"
-- -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/reflocks.py"
-+# -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/refcounter.py"
-+# -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/refstats.py"
-+# -rm -f "$(DESTDIR)$(ASTDATADIR)/scripts/reflocks.py"
diff --git a/net/asterisk16/files/patch-main_Makefile b/net/asterisk16/files/patch-main_Makefile
deleted file mode 100644
index dd0dcda5ce7f..000000000000
--- a/net/asterisk16/files/patch-main_Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- main/Makefile.orig 2020-07-09 15:39:17 UTC
-+++ main/Makefile
-@@ -80,9 +80,12 @@ endif
-
- ifeq ($(OSARCH),FreeBSD)
- # -V is understood by BSD Make, not by GNU make.
-- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
-+ BSDVERSION=$(OSVERSION)
-+ BSDVERSION?=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
- AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
-+ CRYPT_LIB=$(shell if test $(BSDVERSION) -ge 1200001 ; then echo "-lcrypt"; fi)
- AST_LIBS+=-lcrypto
-+ AST_LIBS+=%%LIBSYSINFO%%
- endif
-
- ifneq ($(findstring $(OSARCH), mingw32 cygwin ),)
diff --git a/net/asterisk16/files/patch-main_lock.c b/net/asterisk16/files/patch-main_lock.c
deleted file mode 100644
index 019735f7079f..000000000000
--- a/net/asterisk16/files/patch-main_lock.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- main/lock.c.orig 2020-07-09 15:39:17 UTC
-+++ main/lock.c
-@@ -689,9 +689,6 @@ int __ast_rwlock_init(int tracking, const char *filena
- #endif /* DEBUG_THREADS */
-
- pthread_rwlockattr_init(&attr);
--#ifdef HAVE_PTHREAD_RWLOCK_PREFER_WRITER_NP
-- pthread_rwlockattr_setkind_np(&attr, PTHREAD_RWLOCK_PREFER_WRITER_NP);
--#endif
- res = pthread_rwlock_init(&t->lock, &attr);
- pthread_rwlockattr_destroy(&attr);
-
diff --git a/net/asterisk16/files/patch-main_term.c b/net/asterisk16/files/patch-main_term.c
deleted file mode 100644
index dc7ede7d4e12..000000000000
--- a/net/asterisk16/files/patch-main_term.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- main/term.c.orig 2022-04-14 21:53:34 UTC
-+++ main/term.c
-@@ -46,6 +46,7 @@ static const char * const termpath[] = {
- static char quitdata[80] = "";
-
- static const char * const termpath[] = {
-+ "%%LOCALBASE%%/share/terminfo",
- "/usr/share/terminfo",
- "/usr/local/share/misc/terminfo",
- "/usr/lib/terminfo",
diff --git a/net/asterisk16/files/patch-menuselect_configure b/net/asterisk16/files/patch-menuselect_configure
deleted file mode 100644
index 30b3d50d7a34..000000000000
--- a/net/asterisk16/files/patch-menuselect_configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- menuselect/configure.orig 2022-05-12 11:47:40 UTC
-+++ menuselect/configure
-@@ -5024,7 +5024,7 @@ printf "%s\n" "yes" >&6; }
- printf "%s\n" "yes" >&6; }
-
- PBX_LIBXML2=1
-- LIBXML2_INCLUDE=$(echo ${LIBXML2_CFLAGS} | $SED -e "s|-std=c99||g")
-+ LIBXML2_INCLUDE=$(echo ${LIBXML2_CFLAGS} | sed -e "s|-std=c99||g")
- LIBXML2_LIB="$LIBXML2_LIBS"
-
- printf "%s\n" "#define HAVE_LIBXML2 1" >>confdefs.h
diff --git a/net/asterisk16/files/patch-third-party_pjproject_Makefile b/net/asterisk16/files/patch-third-party_pjproject_Makefile
deleted file mode 100644
index 45ae5db97c97..000000000000
--- a/net/asterisk16/files/patch-third-party_pjproject_Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
---- third-party/pjproject/Makefile.orig 2022-02-03 12:19:37 UTC
-+++ third-party/pjproject/Makefile
-@@ -88,15 +88,11 @@ SHELL_ECHO_PREFIX := echo '[pjproject] '
-
- _all: $(TARGETS)
-
--$(DOWNLOAD_DIR)/$(TARBALL_FILE): ../versions.mak
-- $(CMD_PREFIX) ($(TARBALL_EXISTS) && $(TARBALL_VERIFY) && touch $@) || (rm -rf $@ ;\
-- $(TARBALL_DOWNLOAD)) || (rm -rf $@ ;\
-- $(SHELL_ECHO_PREFIX) Retrying download ; $(TARBALL_DOWNLOAD))
-+$(DOWNLOAD_DIR)/$(TARBALL_FILE):
-+ @true
-
- source/.unpacked: $(DOWNLOAD_DIR)/$(TARBALL_FILE)
-- $(CMD_PREFIX) \
-- $(TARBALL_VERIFY) || (rm -rf $@ ; $(SHELL_ECHO_PREFIX) Retrying download ; $(TARBALL_DOWNLOAD)) ;\
-- $(SHELL_ECHO_PREFIX) Unpacking $< ;\
-+ $(SHELL_ECHO_PREFIX) Unpacking $< ;\
- rm -rf source pjproject-*/ $(REALLY_QUIET) || : ;\
- $(TAR) -xjf $< ;\
- mv pjproject-$(PJPROJECT_VERSION) source
-@@ -202,7 +198,7 @@ $(ALL_LIB_FILES): source/build.mak source/pjlib/includ
-
- pjproject.symbols: $(ALL_LIB_FILES)
- $(ECHO_PREFIX) Generating symbols
-- $(CMD_PREFIX) $(NM) -Pog $(ALL_LIB_FILES) | $(SED) -n -r -e "s/.+: ([pP][jJ][^ ]+) .+/\1/gp" | sort -u > pjproject.symbols
-+ $(CMD_PREFIX) $(NM) -Pog $(ALL_LIB_FILES) | $(SED) -n -r -e "s/^([pP][jJ][^ ]+) .+/\1/gp" | sort -u > pjproject.symbols
-
- source/pjsip-apps/src/asterisk_malloc_debug.c: patches/asterisk_malloc_debug.c
- $(ECHO_PREFIX) Copying $< to $@
diff --git a/net/asterisk16/files/patch-third-party_pjproject_Makefile.rules b/net/asterisk16/files/patch-third-party_pjproject_Makefile.rules
deleted file mode 100644
index 424b4f4a3740..000000000000
--- a/net/asterisk16/files/patch-third-party_pjproject_Makefile.rules
+++ /dev/null
@@ -1,20 +0,0 @@
---- third-party/pjproject/Makefile.rules.orig 2020-07-09 15:39:17 UTC
-+++ third-party/pjproject/Makefile.rules
-@@ -7,7 +7,7 @@
- # PACKAGE_URL ?= http://www.pjsip.org/release/$(PJPROJECT_VERSION)
-
- PACKAGE_URL ?= https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/$(PJPROJECT_VERSION)
--TARBALL_FILE = pjproject-$(PJPROJECT_VERSION).tar.bz2
-+TARBALL_FILE = pjsip-pjproject-$(PJPROJECT_VERSION)_GH0.tar.gz
-
- # PJPROJECT_CONFIGURE_OPTS could come from the command line or could be
- # set/modified by configure.m4 if the build or host tuples aren't the same
-@@ -37,7 +37,7 @@ PJPROJECT_CONFIG_OPTS = $(PJPROJECT_CONFIGURE_OPTS) --
- --disable-ipp \
- --disable-libwebrtc \
- --without-external-pa \
-- --without-external-srtp
-+ --with-external-srtp
-
- ifneq ($(AST_DEVMODE),yes)
- PJPROJECT_CONFIG_OPTS += --disable-resample --disable-g711-codec