aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk18
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk18')
-rw-r--r--net/asterisk18/files/patch-Makefile36
-rw-r--r--net/asterisk18/files/patch-build__tools_make__xml__documentation4
-rw-r--r--net/asterisk18/files/patch-channels_chan__dahdi.c8
-rw-r--r--net/asterisk18/files/patch-channels_sip_include_sip.h4
-rw-r--r--net/asterisk18/files/patch-configure22
-rw-r--r--net/asterisk18/files/patch-main_Makefile16
-rw-r--r--net/asterisk18/files/patch-main_term.c4
-rw-r--r--net/asterisk18/files/patch-menuselect_configure4
8 files changed, 54 insertions, 44 deletions
diff --git a/net/asterisk18/files/patch-Makefile b/net/asterisk18/files/patch-Makefile
index b63c2c5294a0..051f9509b8ab 100644
--- a/net/asterisk18/files/patch-Makefile
+++ b/net/asterisk18/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2022-07-28 15:51:18 UTC
+--- Makefile.orig 2022-08-18 15:18:29 UTC
+++ Makefile
-@@ -144,7 +144,7 @@ OVERWRITE=y
+@@ -144,7 +144,7 @@ ASTTOPDIR:=$(subst $(space),\$(space),$(CURDIR))
OVERWRITE=y
# Include debug and macro symbols in the executables (-g) and profiling info (-pg)
@@ -18,16 +18,20 @@
# If the file .asterisk.makeopts is present in your home directory, you can
# include all of your favorite menuselect options so that every time you download
-@@ -228,7 +228,7 @@ ifeq ($(OSARCH),FreeBSD)
+@@ -226,12 +226,6 @@ else ifneq ($(findstring BSD,$(OSARCH)),)
+ _ASTCFLAGS+=-isystem /usr/local/include
+ endif
- ifeq ($(OSARCH),FreeBSD)
- # -V is understood by BSD Make, not by GNU make.
+-ifeq ($(OSARCH),FreeBSD)
+- # -V is understood by BSD Make, not by GNU make.
- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
-+ BSDVERSION=$(OSVERSION)
- _ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
+- _ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
+-endif
+-
+ ifeq ($(OSARCH),NetBSD)
+ _ASTCFLAGS+=-pthread -D__LIBPTHREAD_SOURCE__ -I/usr/pkg/include
endif
-
-@@ -475,8 +475,12 @@ endif
+@@ -475,8 +469,12 @@ endif
$(INSTALL) -m 644 $$n "$(DESTDIR)$(ASTDATADIR)/static-http/docs" ; \
done \
fi
@@ -41,7 +45,7 @@
done
$(MAKE) -C sounds install
find rest-api -name "*.json" | while read x; do \
-@@ -545,7 +549,7 @@ INSTALLDIRS="$(ASTLIBDIR)" "$(ASTMODDIR)" "$(ASTSBINDI
+@@ -545,7 +543,7 @@ INSTALLDIRS="$(ASTLIBDIR)" "$(ASTMODDIR)" "$(ASTSBINDI
"$(ASTDATADIR)/firmware/iax" "$(ASTDATADIR)/images" "$(ASTDATADIR)/keys" \
"$(ASTDATADIR)/phoneprov" "$(ASTDATADIR)/rest-api" "$(ASTDATADIR)/static-http" \
"$(ASTDATADIR)/sounds" "$(ASTDATADIR)/moh" "$(ASTMANDIR)/man8" "$(AGI_DIR)" "$(ASTDBDIR)" \
@@ -50,7 +54,7 @@
installdirs:
@for i in $(INSTALLDIRS); do \
-@@ -557,7 +561,7 @@ main-bininstall:
+@@ -557,7 +555,7 @@ installdirs:
main-bininstall:
+@DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" ASTLIBDIR="$(ASTLIBDIR)" $(SUBMAKE) -C main bininstall
@@ -59,7 +63,7 @@
$(INSTALL) -m 755 contrib/scripts/astversion "$(DESTDIR)$(ASTSBINDIR)/"
$(INSTALL) -m 755 contrib/scripts/astgenkey "$(DESTDIR)$(ASTSBINDIR)/"
$(INSTALL) -m 755 contrib/scripts/autosupport "$(DESTDIR)$(ASTSBINDIR)/"
-@@ -578,10 +582,10 @@ endif
+@@ -578,10 +576,10 @@ endif
if [ -f contrib/firmware/iax/iaxy.bin ] ; then \
$(INSTALL) -m 644 contrib/firmware/iax/iaxy.bin "$(DESTDIR)$(ASTDATADIR)/firmware/iax/iaxy.bin"; \
fi
@@ -74,7 +78,7 @@
$(SUBDIRS_INSTALL):
+@DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" ASTDATADIR="$(ASTDATADIR)" $(SUBMAKE) -C $(@:-install=) install
-@@ -706,7 +710,7 @@ endif
+@@ -706,7 +704,7 @@ ifeq ($(ASTERISKVERSION),UNKNOWN__git_check_fail)
endif
@@ -83,7 +87,7 @@
@if [ -x /usr/sbin/asterisk-post-install ]; then \
/usr/sbin/asterisk-post-install "$(DESTDIR)" . ; \
fi
-@@ -751,23 +755,10 @@ define INSTALL_CONFIGS
+@@ -751,23 +749,10 @@ upgrade: bininstall
# (2) the extension to strip off
define INSTALL_CONFIGS
@for x in $(1)/*$(2); do \
@@ -109,7 +113,7 @@
echo "Updating asterisk.conf" ; \
sed -e 's|^astcachedir.*$$|astcachedir => $(ASTCACHEDIR)|' \
-e 's|^astetcdir.*$$|astetcdir => $(ASTETCDIR)|' \
-@@ -781,8 +772,8 @@ define INSTALL_CONFIGS
+@@ -781,8 +766,8 @@ define INSTALL_CONFIGS
-e 's|^astrundir.*$$|astrundir => $(ASTVARRUNDIR)|' \
-e 's|^astlogdir.*$$|astlogdir => $(ASTLOGDIR)|' \
-e 's|^astsbindir.*$$|astsbindir => $(ASTSBINDIR)|' \
@@ -120,7 +124,7 @@
rm -f "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
fi
endef
-@@ -816,7 +807,7 @@ adsi:
+@@ -816,7 +801,7 @@ adsi:
else \
echo "Installing $$x" ; \
fi ; \
diff --git a/net/asterisk18/files/patch-build__tools_make__xml__documentation b/net/asterisk18/files/patch-build__tools_make__xml__documentation
index c11eac024b64..5306b95775b7 100644
--- a/net/asterisk18/files/patch-build__tools_make__xml__documentation
+++ b/net/asterisk18/files/patch-build__tools_make__xml__documentation
@@ -1,6 +1,6 @@
---- build_tools/make_xml_documentation.orig 2022-03-17 15:40:57 UTC
+--- build_tools/make_xml_documentation.orig 2022-06-23 15:26:13 UTC
+++ build_tools/make_xml_documentation
-@@ -228,7 +228,7 @@ for subdir in ${mod_subdirs} ; do
+@@ -214,7 +214,7 @@ for subdir in ${mod_subdirs} ; do
${XMLSTARLET} val -e -d "${source_tree}/doc/appdocsxml.dtd" "${i}" || { echo "" ; exit 1 ; }
fi
fi
diff --git a/net/asterisk18/files/patch-channels_chan__dahdi.c b/net/asterisk18/files/patch-channels_chan__dahdi.c
index cc294c5ba840..47ab406401f5 100644
--- a/net/asterisk18/files/patch-channels_chan__dahdi.c
+++ b/net/asterisk18/files/patch-channels_chan__dahdi.c
@@ -1,6 +1,6 @@
---- channels/chan_dahdi.c.orig 2020-07-09 15:39:17 UTC
+--- channels/chan_dahdi.c.orig 2022-08-18 15:18:29 UTC
+++ channels/chan_dahdi.c
-@@ -4649,6 +4649,8 @@ void dahdi_ec_enable(struct dahdi_pvt *p)
+@@ -4803,6 +4803,8 @@ void dahdi_ec_enable(struct dahdi_pvt *p)
return;
}
if (p->echocancel.head.tap_length) {
@@ -9,7 +9,7 @@
#if defined(HAVE_PRI) || defined(HAVE_SS7)
switch (p->sig) {
#if defined(HAVE_PRI)
-@@ -4679,7 +4681,9 @@ void dahdi_ec_enable(struct dahdi_pvt *p)
+@@ -4833,7 +4835,9 @@ void dahdi_ec_enable(struct dahdi_pvt *p)
break;
}
#endif /* defined(HAVE_PRI) || defined(HAVE_SS7) */
@@ -20,7 +20,7 @@
if (res) {
ast_log(LOG_WARNING, "Unable to enable echo cancellation on channel %d (%s)\n", p->channel, strerror(errno));
} else {
-@@ -4713,8 +4717,9 @@ void dahdi_ec_disable(struct dahdi_pvt *p)
+@@ -4867,8 +4871,9 @@ void dahdi_ec_disable(struct dahdi_pvt *p)
if (p->echocanon) {
struct dahdi_echocanparams ecp = { .tap_length = 0 };
diff --git a/net/asterisk18/files/patch-channels_sip_include_sip.h b/net/asterisk18/files/patch-channels_sip_include_sip.h
index d1668bf70598..68d93f730e4f 100644
--- a/net/asterisk18/files/patch-channels_sip_include_sip.h
+++ b/net/asterisk18/files/patch-channels_sip_include_sip.h
@@ -1,6 +1,6 @@
---- channels/sip/include/sip.h.orig 2020-07-09 15:39:17 UTC
+--- channels/sip/include/sip.h.orig 2022-06-23 15:26:13 UTC
+++ channels/sip/include/sip.h
-@@ -192,7 +192,7 @@
+@@ -193,7 +193,7 @@
#define DEFAULT_MOHINTERPRET "default" /*!< The default music class */
#define DEFAULT_MOHSUGGEST ""
#define DEFAULT_VMEXTEN "asterisk" /*!< Default voicemail extension */
diff --git a/net/asterisk18/files/patch-configure b/net/asterisk18/files/patch-configure
index a66863381c74..d8a559d1d32d 100644
--- a/net/asterisk18/files/patch-configure
+++ b/net/asterisk18/files/patch-configure
@@ -1,4 +1,4 @@
---- configure.orig 2022-05-05 17:09:31 UTC
+--- configure.orig 2022-06-23 15:26:13 UTC
+++ configure
@@ -5156,8 +5156,6 @@ case "${host_os}" in
;;
@@ -9,7 +9,15 @@
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -22983,6 +22981,8 @@ printf %s "checking for getifaddrs() support... " >&6;
+@@ -21341,7 +21339,6 @@ then :
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ printf "%s\n" "yes" >&6; }
+
+-printf "%s\n" "#define HAVE_SYSINFO 1" >>confdefs.h
+
+ else $as_nop
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
+@@ -22983,6 +22980,8 @@ printf %s "checking for getifaddrs() support... " >&6;
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -18,7 +26,7 @@
#include <ifaddrs.h>
int
main (void)
-@@ -32380,6 +32380,8 @@ for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
+@@ -32380,6 +32379,8 @@ fi
for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
@@ -27,7 +35,7 @@
if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no"; then
pbxlibdir=""
# if --with-LUA=DIR has been specified, use it.
-@@ -32394,14 +32396,14 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
+@@ -32394,14 +32395,14 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
ast_ext_lib_check_save_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} "
as_ac_Lib=`printf "%s\n" "ac_cv_lib_lua${ver}""_luaL_newstate" | $as_tr_sh`
@@ -45,7 +53,7 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -32442,7 +32444,7 @@ fi
+@@ -32442,7 +32443,7 @@ fi
# now check for the header.
if test "${AST_LUA_FOUND}" = "yes"; then
@@ -54,7 +62,7 @@
# if --with-LUA=DIR has been specified, use it.
if test "x${LUA_DIR}" != "x"; then
LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -32452,8 +32454,8 @@ fi
+@@ -32452,8 +32453,8 @@ fi
# check for the header
ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
@@ -65,7 +73,7 @@
if eval test \"x\$"$as_ac_Header"\" = x"yes"
then :
LUA_HEADER_FOUND=1
-@@ -32480,9 +32482,9 @@ fi
+@@ -32480,9 +32481,9 @@ fi
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then
diff --git a/net/asterisk18/files/patch-main_Makefile b/net/asterisk18/files/patch-main_Makefile
index dd0dcda5ce7f..62f7a4504a4e 100644
--- a/net/asterisk18/files/patch-main_Makefile
+++ b/net/asterisk18/files/patch-main_Makefile
@@ -1,16 +1,14 @@
---- main/Makefile.orig 2020-07-09 15:39:17 UTC
+--- main/Makefile.orig 2022-08-18 15:18:29 UTC
+++ main/Makefile
-@@ -80,9 +80,12 @@ endif
+@@ -79,9 +79,8 @@ else
+ endif
ifeq ($(OSARCH),FreeBSD)
- # -V is understood by BSD Make, not by GNU make.
+- # -V is understood by BSD Make, not by GNU make.
- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
-+ BSDVERSION=$(OSVERSION)
-+ BSDVERSION?=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
- AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
-+ CRYPT_LIB=$(shell if test $(BSDVERSION) -ge 1200001 ; then echo "-lcrypt"; fi)
+- AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
++ AST_LIBS+=-pthread
++ CRYPT_LIB=-lcrypt
AST_LIBS+=-lcrypto
-+ AST_LIBS+=%%LIBSYSINFO%%
endif
- ifneq ($(findstring $(OSARCH), mingw32 cygwin ),)
diff --git a/net/asterisk18/files/patch-main_term.c b/net/asterisk18/files/patch-main_term.c
index dc7ede7d4e12..37ead1579249 100644
--- a/net/asterisk18/files/patch-main_term.c
+++ b/net/asterisk18/files/patch-main_term.c
@@ -1,6 +1,6 @@
---- main/term.c.orig 2022-04-14 21:53:34 UTC
+--- main/term.c.orig 2022-06-23 15:26:13 UTC
+++ main/term.c
-@@ -46,6 +46,7 @@ static const char * const termpath[] = {
+@@ -46,6 +46,7 @@ static char enddata[80] = "";
static char quitdata[80] = "";
static const char * const termpath[] = {
diff --git a/net/asterisk18/files/patch-menuselect_configure b/net/asterisk18/files/patch-menuselect_configure
index 0447a4c09766..0bba133d6749 100644
--- a/net/asterisk18/files/patch-menuselect_configure
+++ b/net/asterisk18/files/patch-menuselect_configure
@@ -1,6 +1,6 @@
---- menuselect/configure.orig 2022-05-12 11:50:59 UTC
+--- menuselect/configure.orig 2022-06-23 15:26:13 UTC
+++ menuselect/configure
-@@ -5024,7 +5024,7 @@ printf "%s\n" "yes" >&6; }
+@@ -5099,7 +5099,7 @@ else
printf "%s\n" "yes" >&6; }
PBX_LIBXML2=1