aboutsummaryrefslogtreecommitdiff
path: root/net/delegate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/delegate/Makefile')
-rw-r--r--net/delegate/Makefile31
1 files changed, 2 insertions, 29 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 207f3ea17781..b125a842bd9b 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -6,42 +6,16 @@
#
PORTNAME= delegate
-PORTVERSION= 6.1.22
-CATEGORIES= net www japanese
+PORTVERSION= 7.1.2
+CATEGORIES= net www
MASTER_SITES= ftp://ftp.delegate.org/pub/DeleGate/ \
ftp://ftp.etl.go.jp/pub/DeleGate/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= max@FreeBSD.org
-NO_PACKAGE= "Insecure program."
IS_INTERACTIVE= YES
-pre-fetch:
-.if !defined(FORCE_BUILD) || ${FORCE_BUILD}!="YES"
- @${ECHO} "*********************************************************************"
- @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
- @${ECHO} "* This program has know security problems which may allow a remote *"
- @${ECHO} "* attacker to take control of your machine. *"
- @${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
- @${ECHO} "* *"
- @${ECHO} "* It is strongly recommended that you avoid using this program. *"
- @${ECHO} "* *"
- @${ECHO} "* If you would like to use this program despite the danger, run *"
- @${ECHO} "* make with ``FORCE_BUILD=YES'' *"
- @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
- @${ECHO} "*********************************************************************"
- @${FALSE}
-.else
- @${ECHO} "*********************************************************************"
- @${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
- @${ECHO} "* You have chosen to build an insecure program. *"
- @${ECHO} "* This program has know security problems which may allow a remote *"
- @${ECHO} "* attacker to take control of your machine. *"
- @${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
- @${ECHO} "*********************************************************************"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/delegated ${PREFIX}/sbin
@${MKDIR} ${PREFIX}/share/examples/delegate
@@ -52,6 +26,5 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/Manual.htm \
${PREFIX}/share/doc/delegate
.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>