aboutsummaryrefslogtreecommitdiff
path: root/net/fb303/files/patch-fb303_thrift_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'net/fb303/files/patch-fb303_thrift_CMakeLists.txt')
-rw-r--r--net/fb303/files/patch-fb303_thrift_CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/fb303/files/patch-fb303_thrift_CMakeLists.txt b/net/fb303/files/patch-fb303_thrift_CMakeLists.txt
new file mode 100644
index 000000000000..07717fcee34b
--- /dev/null
+++ b/net/fb303/files/patch-fb303_thrift_CMakeLists.txt
@@ -0,0 +1,22 @@
+--- fb303/thrift/CMakeLists.txt.orig 2020-09-15 21:56:05 UTC
++++ fb303/thrift/CMakeLists.txt
+@@ -15,7 +15,7 @@
+ add_fbthrift_library(
+ fb303_thrift
+ fb303_core.thrift
+- LANGUAGES cpp py
++ LANGUAGES cpp
+ THRIFT_INCLUDE_DIR "${INCLUDE_INSTALL_DIR}/thrift-files"
+ SERVICES
+ BaseService
+@@ -38,8 +38,10 @@ install(
+ DESTINATION "$<TARGET_PROPERTY:fb303_thrift_cpp,THRIFT_INSTALL_DIR>"
+ )
+
++if (FALSE)
+ install_fb_python_library(fb303_thrift_py EXPORT fb303-exports)
+ install(
+ TARGETS fb303_thrift_py.thrift_includes
+ EXPORT fb303-exports
+ )
++endif()