aboutsummaryrefslogtreecommitdiff
path: root/net/gtk-vnc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gtk-vnc/Makefile')
-rw-r--r--net/gtk-vnc/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/gtk-vnc/Makefile b/net/gtk-vnc/Makefile
new file mode 100644
index 000000000000..5ab9e0481b28
--- /dev/null
+++ b/net/gtk-vnc/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gtk-vnc
+# Date created: 16 December 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-vnc
+PORTVERSION= 0.3.1
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtk-vnc
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= VNC viewer widget for GTK+
+
+LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
+
+USE_XLIB= yes
+USE_GNOME= pygtk2 gnomehack
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_PYTHON= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>