aboutsummaryrefslogtreecommitdiff
path: root/net/gupnp-tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gupnp-tools/Makefile')
-rw-r--r--net/gupnp-tools/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/gupnp-tools/Makefile b/net/gupnp-tools/Makefile
index 828e7ccd4087..f7fb6806faf7 100644
--- a/net/gupnp-tools/Makefile
+++ b/net/gupnp-tools/Makefile
@@ -1,26 +1,30 @@
PORTNAME= gupnp-tools
-PORTVERSION= 0.10.3
+PORTVERSION= 0.12.1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= GNOME
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Set of utilities and demos to work with UPnP
+WWW= https://wiki.gnome.org/Projects/GUPnP \
+ https://gitlab.gnome.org/GNOME/gupnp-tools
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= glib>=2.24:devel/glib20 \
- gssdp14>=1.2.0:net/gssdp14 \
+BUILD_DEPENDS= glib>=2.68:devel/glib20 \
+ gssdp>=1.6.2:net/gssdp \
gtk3>=3.10:x11-toolkits/gtk30 \
- gupnp14>=1.4.0:net/gupnp14 \
- libsoup>=2.42:devel/libsoup
-LIB_DEPENDS= libgssdp-1.2.so:net/gssdp14 \
- libgupnp-1.2.so:net/gupnp14 \
- libsoup-2.4.so:devel/libsoup
+ gupnp>=1.6.0:net/gupnp \
+ libsoup3>=3.0:devel/libsoup3
+LIB_DEPENDS= libgssdp-1.6.so:net/gssdp \
+ libgupnp-1.6.so:net/gupnp \
+ libsoup-3.0.so:devel/libsoup3
USES= gettext-tools gnome meson pkgconfig tar:xz
USE_GNOME= glib20 gtk30 libxml2
+CFLAGS+= -Wno-error=deprecated-declarations
USE_LDCONFIG= yes
OPTIONS_DEFINE= AV_TOOLS