aboutsummaryrefslogtreecommitdiff
path: root/net/htpdate
diff options
context:
space:
mode:
Diffstat (limited to 'net/htpdate')
-rw-r--r--net/htpdate/Makefile29
-rw-r--r--net/htpdate/distinfo2
-rw-r--r--net/htpdate/pkg-descr9
3 files changed, 40 insertions, 0 deletions
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
new file mode 100644
index 000000000000..aa99b27e91f9
--- /dev/null
+++ b/net/htpdate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: htpdate
+# Date created: 9 Jun 2005
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htpdate
+PORTVERSION= 0.8.1
+CATEGORIES= net
+MASTER_SITES= http://www.clevervest.com/htp/archive/c/
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Time synchronization over http utility
+
+USE_BZIP2= yes
+
+MAN8= htpdate.8
+
+PLIST_FILES= bin/htpdate
+
+post-extract:
+ @${GZIP_CMD} -d ${WRKSRC}/${MAN8}.gz
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/htpdate ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/net/htpdate/distinfo b/net/htpdate/distinfo
new file mode 100644
index 000000000000..3e7eef1f1d40
--- /dev/null
+++ b/net/htpdate/distinfo
@@ -0,0 +1,2 @@
+MD5 (htpdate-0.8.1.tar.bz2) = 17e9d66a9eaa4b9bceb5badfed19ce12
+Size (htpdate-0.8.1.tar.bz2) = 10416
diff --git a/net/htpdate/pkg-descr b/net/htpdate/pkg-descr
new file mode 100644
index 000000000000..3f8c4339c00b
--- /dev/null
+++ b/net/htpdate/pkg-descr
@@ -0,0 +1,9 @@
+The HTTP Time Protocol (HTP) is used to synchronize a computer's time
+with web servers as reference time source. Htpdate will synchronize your
+computer's time by extracting timestamps from HTTP headers found
+in web servers responses. Htpdate can be used as a daemon, to keep your
+computer synchronized.
+Accuracy of htpdate is usually better than 0.5 seconds (even better with
+multiple servers). Htpdate can also work through http proxy.
+
+WWW: http://www.clevervest.com/htp/