aboutsummaryrefslogtreecommitdiff
path: root/net/imm
diff options
context:
space:
mode:
Diffstat (limited to 'net/imm')
-rw-r--r--net/imm/Makefile47
-rw-r--r--net/imm/distinfo3
-rw-r--r--net/imm/files/Makefile.freebsd77
-rw-r--r--net/imm/files/Makefile.work2
-rw-r--r--net/imm/files/patch-aa11
-rw-r--r--net/imm/files/patch-ab11
-rw-r--r--net/imm/files/patch-ac11
-rw-r--r--net/imm/files/patch-src-tkAppInit.c12
-rw-r--r--net/imm/files/patch-src::utils.c200
-rw-r--r--net/imm/pkg-descr10
-rw-r--r--net/imm/pkg-plist5
11 files changed, 0 insertions, 389 deletions
diff --git a/net/imm/Makefile b/net/imm/Makefile
deleted file mode 100644
index 7ad7149eed3c..000000000000
--- a/net/imm/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: imm
-# Date created: 13 October 1994
-# Whom: wollman
-#
-# $FreeBSD$
-#
-
-PORTNAME= imm
-PORTVERSION= 3.5a1
-PORTREVISION= 3
-CATEGORIES= mbone tk
-MASTER_SITES= ftp://ftp.hawaii.edu/paccom/imm-3.5a1/
-DISTNAME= imm.source
-EXTRACT_SUFX= .tar.Z
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Internet Image(or other data) Multicaster (and receiver)
-
-USE_TK= 84
-WRKSRC= ${WRKDIR}/mnm
-
-PORTDOCS= README imm_readme.txt
-
-.include <bsd.port.pre.mk>
-
-post-extract:
- @${MKDIR} ${WRKSRC}/freebsd
- @${CP} ${FILESDIR}/Makefile.work ${WRKSRC}/Makefile
- @${CP} ${FILESDIR}/Makefile.freebsd ${WRKSRC}/src
-
-# The included makefile doesn't have an "install" target.
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/imm ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/immserv ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/lscomp ${PREFIX}/bin
-# and no man pages at all yet.
-# But include the very limited documentation
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/imm_readme.txt ${DOCSDIR}
-.endif
-# The sdr plugin is pretty much required.
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/sdr2.plugin.S53.image.imm ${DATADIR}
-
-.include <bsd.port.post.mk>
diff --git a/net/imm/distinfo b/net/imm/distinfo
deleted file mode 100644
index 090e9df901b5..000000000000
--- a/net/imm/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (imm.source.tar.Z) = bf2713e5dca81daaecbc0bbcaf7af667
-SHA256 (imm.source.tar.Z) = be66dc74b955cf51de1575662d700b87cb423e3562f163d2f0dc70878b73270b
-SIZE (imm.source.tar.Z) = 106067
diff --git a/net/imm/files/Makefile.freebsd b/net/imm/files/Makefile.freebsd
deleted file mode 100644
index 379dae4d11a3..000000000000
--- a/net/imm/files/Makefile.freebsd
+++ /dev/null
@@ -1,77 +0,0 @@
-# Some versions of make, like SGI's, use the following variable to
-# determine which shell to use for executing commands:
-SHELL = /bin/sh
-INCLUDE_DIR = -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 -I${LOCALBASE}/include
-# Libraries to use when linking:
-LIBS = -lm
-
-TKLIBS= -L$(PREFIX)/lib -L${LOCALBASE}/lib -ltk84 -ltcl84 -lX11
-
-TARGET = ../freebsd
-
-CFLAGS = -g -DSIG_T=void -DMULTICAST -I. -DERROR_TEST
-
-CC ?= gcc
-CC_SWITCHES = ${CFLAGS}
-
-ROBJS = protocol.o utils.o
-
-SOBJS = protocol.o immserv.o sorttree.o utils.o
-
-MOBJS = protocol.o mnmserver.o sorttree.o utils.o
-
-all: $(TARGET)/imm $(TARGET)/immserv $(TARGET)/lscomp
-
-$(TARGET)/mnm: $(ROBJS) main.o xlopen.o mcl.o
- $(CC) $(CFLAGS) main.o xlopen.o mcl.o $(ROBJS) $(LIBS) -o $(TARGET)/mnm
-
-$(TARGET)/imm: $(ROBJS) tkAppInit.o imm_init.o imm.o xlopen_imm.o
- $(CC) $(CFLAGS) tkAppInit.o imm_init.o imm.o xlopen_imm.o $(ROBJS) $(TKLIBS) $(LIBS) -o $(TARGET)/imm
-
-$(TARGET)/immserv: $(SOBJS)
- $(CC) $(CFLAGS) $(SOBJS) $(LIBS) -o $(TARGET)/immserv
-
-$(TARGET)/lscomp: lscomp.o protocol.o sorttree.o utils.o
- $(CC) $(CFLAGS) lscomp.o protocol.o sorttree.o utils.o $(LIBS) -o $(TARGET)/lscomp
-
-clean:
- rm -f *.o tcl2c $(TARGET)/mnm $(TARGET)/lscomp $(TARGET)/imm $(TARGET)/immserv
-
-tcl2c: tcl2c.c
- $(CC) $(CFLAGS) tcl2c.c $(LIBS) -o tcl2c
-
-imm_init.c: tcl2c imm_def.tcl mcl.tcl Radio.tcl Listbox.tcl viewbox.tcl filebox.tcl mkHostname.tcl
- ./tcl2c IMM_Init < imm_def.tcl > imm_init.c
- ./tcl2c MCL < mcl.tcl >> imm_init.c
- ./tcl2c RADIO < Radio.tcl >> imm_init.c
- ./tcl2c LISTBOX < Listbox.tcl >> imm_init.c
- ./tcl2c VIEWBOX < viewbox.tcl >> imm_init.c
- ./tcl2c FILEBOX < filebox.tcl >> imm_init.c
- ./tcl2c HOSTBOX < mkHostname.tcl >> imm_init.c
- ./tcl2c SERVERBOX < mnmserv.tcl >> imm_init.c
-
-imm_init.o: imm_init.c
-
-main.o: main.c
-
-mcl.o: mcl.c
-
-imm.o: mcl.c
- gcc $(CFLAGS) -DIMM $(INCLUDE_DIR) -c mcl.c -o imm.o
-
-xlopen_imm.o: xlopen.c
- gcc $(CFLAGS) -DIMM $(INCLUDE_DIR) -c xlopen.c -o xlopen_imm.o
-
-tkAppInit.o: tkAppInit.c
- gcc $(CFLAGS) $(INCLUDE_DIR) tkAppInit.c -c
-
-protocol.o: protocol.c
-
-utils.o: utils.c
-
-lscomp.o: lscomp.c
-
-sorttree.o: sorttree.c immserv.h
-
-immserv.o: immserv.c immserv.h
-
diff --git a/net/imm/files/Makefile.work b/net/imm/files/Makefile.work
deleted file mode 100644
index cb876d343f9e..000000000000
--- a/net/imm/files/Makefile.work
+++ /dev/null
@@ -1,2 +0,0 @@
-all install:
- cd src; ${MAKE} -f Makefile.freebsd $@
diff --git a/net/imm/files/patch-aa b/net/imm/files/patch-aa
deleted file mode 100644
index f7cb9a9cefc8..000000000000
--- a/net/imm/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mcl.c.orig Tue Nov 19 12:33:49 1996
-+++ src/mcl.c Tue Nov 19 12:34:23 1996
-@@ -25,7 +25,7 @@
-
- #define MAIN
- #include "protocol.h"
--#include <malloc.h>
-+#include <stdlib.h>
- #include <fcntl.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
diff --git a/net/imm/files/patch-ab b/net/imm/files/patch-ab
deleted file mode 100644
index 4b1f038304da..000000000000
--- a/net/imm/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xlopen.c.orig Tue Nov 19 12:33:53 1996
-+++ src/xlopen.c Tue Nov 19 12:35:01 1996
-@@ -34,7 +34,7 @@
- extern int optind, opterr;
- extern int useimageloader;
- extern struct hosttype *hosts_tail;
--#ifndef __NetBSD__
-+#if !defined(__NetBSD__) && !defined(__FreeBSD__) /* XXX */
- extern char *sys_errlist[];
- #endif
- extern unsigned int total;
diff --git a/net/imm/files/patch-ac b/net/imm/files/patch-ac
deleted file mode 100644
index 2da9e3a99e12..000000000000
--- a/net/imm/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/immserv.c.orig Tue Nov 19 12:36:41 1996
-+++ src/immserv.c Tue Nov 19 12:37:32 1996
-@@ -1407,7 +1407,7 @@
- /******************************************************************************/
- void setackalarm(int nop) {}
- /******************************************************************************/
--#ifndef __NetBSD__
-+#if !defined(__NetBSD__) && !defined(__FreeBSD__) /* XXX */
- /* routine to put process to sleep */
- int usleep( wait)
- u_int wait;
diff --git a/net/imm/files/patch-src-tkAppInit.c b/net/imm/files/patch-src-tkAppInit.c
deleted file mode 100644
index 8dacd5fa95aa..000000000000
--- a/net/imm/files/patch-src-tkAppInit.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/tkAppInit.c.orig Thu Mar 15 10:00:05 2007
-+++ src/tkAppInit.c Thu Mar 15 10:00:12 2007
-@@ -97,9 +97,6 @@
- * Sun shared libraries to be used for Tcl.
- */
-
--extern int matherr();
--void GetDspStatus();
--int *tclDummyMathPtr = (int *) matherr;
-
- /***************************************************************************/
- /* fork and initiate server process */
diff --git a/net/imm/files/patch-src::utils.c b/net/imm/files/patch-src::utils.c
deleted file mode 100644
index a7db5d4e2d04..000000000000
--- a/net/imm/files/patch-src::utils.c
+++ /dev/null
@@ -1,200 +0,0 @@
---- src/utils.c.orig Thu Jul 15 12:37:25 2004
-+++ src/utils.c Thu Jul 15 13:36:09 2004
-@@ -20,7 +20,7 @@
- * These notices must be retained in any copies of any part of this software.
- ******************************************************************************/
- #include <stdio.h>
--#include <varargs.h>
-+#include <stdarg.h>
- #include <stdlib.h>
- #include <string.h>
- #ifdef __NetBSD__
-@@ -40,47 +40,118 @@
-
- /*----------------------------------------------------------------------------*/
-
--void warn( va_alist )
--va_dcl
-+/* Allocate memory for format string buffers */
-+int
-+vfsalloc(char *fmt, va_list ap)
- {
-- va_list args;
-- char *fmt;
-+ char *s;
-+ int i, n = 0, len = 0;
-
-- va_start( args );
-- fmt = va_arg( args, char * );
-- fprintf( stderr, "Warning: " );
-- vfprintf( stderr, fmt, args );
-- va_end( args );
-+ if (!fmt)
-+ return 0;
-+
-+ s = strchr(fmt, '%');
-+
-+ while (s) {
-+ ++s;
-+ ++n;
-+
-+ switch (*s) {
-+ case 'd':
-+ i = va_arg(ap, int);
-+ len += 1 + sizeof(int)<<1;
-+ break;
-+ case 's':
-+ len += strlen(va_arg(ap, char *));
-+ break;
-+ }
-+ s = strchr(s, '%');
-+ }
-+
-+ len += strlen(fmt) - (2 * n);
-+
-+ return len;
-+}
-+
-+void warn( char *fmt, ... )
-+{
-+ va_list ap;
-+ char *buf, *s;
-+ int len;
-+
-+ if (!fmt)
-+ return;
-+
-+ va_start(ap, fmt);
-+ if (!(len = vfsalloc(fmt, ap)))
-+ return;
-+ va_end(ap);
-+
-+ if (!(buf = malloc(len)))
-+ return;
-+
-+ va_start(ap, fmt);
-+ vsprintf(buf, fmt, ap);
-+ va_end(ap);
-+
-+ fprintf(stderr, "Warning: %s\n", buf);
-+ free(buf);
- }
-
- /*----------------------------------------------------------------------------*/
-
--void die( va_alist )
--va_dcl
-+void die(char *fmt, ... )
- {
-- va_list args;
-- char *fmt;
-+ va_list ap;
-+ char *buf, *s;
-+ int len;
-+
-+ if (!fmt)
-+ return;
-+
-+ va_start(ap, fmt);
-+ if (!(len = vfsalloc(fmt, ap)))
-+ return;
-+ va_end(ap);
-+
-+ if (!(buf = malloc(len)))
-+ return;
-
-- va_start( args );
-- fmt = va_arg( args, char * );
-- fprintf( stderr, "Error: " );
-- vfprintf( stderr, fmt, args );
-- exit( 1 );
-+ va_start(ap, fmt);
-+ vsprintf(buf, fmt, ap);
-+ va_end(ap);
-+
-+ fprintf(stderr, "Error: %s\n", buf);
-+ free(buf);
-+ exit(1);
- }
-
- /*----------------------------------------------------------------------------*/
-
--void fatal( va_alist )
--va_dcl
-+void fatal(char *fmt, ... )
- {
-- va_list args;
-- char *fmt;
-+ va_list ap;
-+ char *buf, *s;
-+ int len;
-+
-+ if (!fmt)
-+ return;
-
-- va_start( args );
-- fmt = va_arg( args, char * );
-- fprintf( stderr, "Internal Error: " );
-- vfprintf( stderr, fmt, args );
-- exit( 2 );
-+ va_start(ap, fmt);
-+ if (!(len = vfsalloc(fmt, ap)))
-+ return;
-+ va_end(ap);
-+
-+ if (!(buf = malloc(len)))
-+ return;
-+
-+ va_start(ap, fmt);
-+ vsprintf(buf, fmt, ap);
-+ va_end(ap);
-+
-+ fprintf(stderr, "Internal error: %s\n", buf);
-+ free(buf);
-+ exit(2);
- }
-
- /*----------------------------------------------------------------------------*/
-@@ -142,21 +213,34 @@
-
- /*----------------------------------------------------------------------------*/
-
--void mailmessage( va_alist )
--va_dcl
-+void mailmessage(char *fmt, ... )
- {
-- va_list args;
-- char *fmt;
-+ va_list ap;
-+ char *buf, s;
-+ int len;
- FILE *popen(), *fp;
- char cmdline[80];
- if (whome == NULL) whome = getlogin();
- sprintf(cmdline,"%s %s",mailprog,whome);
- fp = popen(cmdline,"w");
-- va_start( args );
-- fmt = va_arg( args, char * );
-- fprintf( fp, "MNM Warning: " );
-- vfprintf( fp, fmt, args );
-- va_end( args );
-+
-+ if (!fmt)
-+ return;
-+
-+ va_start(ap, fmt);
-+ if (!(len = vfsalloc(fmt, ap)))
-+ return;
-+ va_end(ap);
-+
-+ if (!(buf = malloc(len)))
-+ return;
-+
-+ va_start(ap, fmt);
-+ vsprintf(buf, fmt, ap);
-+ va_end(ap);
-+
-+ fprintf(fp, "MNM Warning: %s", buf);
-+ free(buf);
- pclose(fp);
- }
diff --git a/net/imm/pkg-descr b/net/imm/pkg-descr
deleted file mode 100644
index 339f05932750..000000000000
--- a/net/imm/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-IMM has been designed to efficiently replicate files/file directories
-using a reliable dissemination protocol framework and provide archiving
-and post processing features. The default mode of operation is for imm
-to receive and display compressed imagery files (e.g., jpg,gif) using
-xv or xloadimage as a post processor.
-
-This release includes an sdr plug-in, named sdr2.plugin.S53.image.imm,
-which must be installed to participate in MBone alpha testing of imm sessions.
-Usually in a directory called ~home/.sdr/plugins to be found by sdr.
-See the sdr help pages for information on installing plugins.
diff --git a/net/imm/pkg-plist b/net/imm/pkg-plist
deleted file mode 100644
index 726b2b167e2a..000000000000
--- a/net/imm/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/imm
-bin/immserv
-bin/lscomp
-%%DATADIR%%/sdr2.plugin.S53.image.imm
-@dirrm %%DATADIR%%