aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kdenetwork3/Makefile')
-rw-r--r--net/kdenetwork3/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index e801946d2bc4..cc7b590ecb18 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdenetwork
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= net news kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,15 +14,35 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
LIB_DEPENDS= uu.1:${PORTSDIR}/converters/uulib
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
-USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
+MAKE_ENV= ${CONFIGURE_ENV}
pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
${PERL} -pi -e "s:-lpthread:${PTHREAD_LIBS}:g" ${WRKSRC}/knode/Makefile.in
${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
${PERL} -pi -e "s@^AC_CHECK_UTMP_FILE@# AC_CHECK_UTMP_FILE@g" ${WRKSRC}/configure.in