aboutsummaryrefslogtreecommitdiff
path: root/net/kea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kea/Makefile')
-rw-r--r--net/kea/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index 9474d351e67c..73932843da34 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -39,7 +39,7 @@ PORTDOCS= AUTHORS COPYING ChangeLog README \
CONTRIBUTING.md examples code_of_conduct.md \
platforms.rst
-OPTIONS_DEFINE= DOCS MYSQL PGSQL
+OPTIONS_DEFINE= DOCS MYSQL PGSQL SHELL
OPTIONS_SUB= yes
MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}/bin/mysql_config
@@ -52,5 +52,8 @@ PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}/bin/pg_config
PGSQL_CONFIGURE_OFF= --without-pgsql
PGSQL_SUB_LIST= REQ_PGSQL=postgresql
PGSQL_SUB_LIST_OFF= REQ_PGSQL=""
+SHELL_DESC= Install kea-shell(8) (Python)
+SHELL_USES= python:3.5+
+SHELL_CONFIGURE_ON= --enable-shell
.include <bsd.port.mk>