aboutsummaryrefslogtreecommitdiff
path: root/net/libcmis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libcmis/Makefile')
-rw-r--r--net/libcmis/Makefile30
1 files changed, 26 insertions, 4 deletions
diff --git a/net/libcmis/Makefile b/net/libcmis/Makefile
index 9523b27b4df8..722180ca7493 100644
--- a/net/libcmis/Makefile
+++ b/net/libcmis/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libcmis
-PORTVERSION= 0.1.0
-PORTREVISION= 1
+PORTVERSION= 0.3.0
CATEGORIES= net devel
MASTER_SITES= SF/${PORTNAME}
@@ -20,7 +19,30 @@ GNU_CONFIGURE= yes
USE_GNOME= libxml2 gnomehack
USE_GMAKE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
-CONFIGURE_ARGS= --disable-client
+CXXFLAGS+= -std=c++98
+CONFIGURE_ARGS+= --without-man \
+ --with-boost=${LOCALBASE} \
+ --disable-werror
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if exists(/usr/bin/clang) && ${OSVERSION} >= 900014
+CC= /usr/bin/clang
+CPP= /usr/bin/clang-cpp
+CXX= /usr/bin/clang++
+CONFIGURE_ENV+= CXXCPP="${CPP}"
+.else
+BUILD_DEPENDS+= clang-devel>=3.2.r159895:${PORTSDIR}/lang/clang-devel
+USE_BINUTILS= yes
+CC= ${LOCALBASE}/bin/clang
+CPP= ${CC} -E
+CXX= ${LOCALBASE}/bin/clang++
+CONFIGURE_ENV+= CXXCPP="${CXX} -E"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|@WITH_LIBCMIS_MAN_FALSE@|#|g" ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>