aboutsummaryrefslogtreecommitdiff
path: root/net/libgweather/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libgweather/Makefile')
-rw-r--r--net/libgweather/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/net/libgweather/Makefile b/net/libgweather/Makefile
index 6a0bbb9cc7f2..47ce8e23cbd6 100644
--- a/net/libgweather/Makefile
+++ b/net/libgweather/Makefile
@@ -1,31 +1,30 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/net/libgweather/Makefile 17268 2013-04-01 05:13:11Z marcus $
+# $MCom: ports/trunk/net/libgweather/Makefile 20031 2014-11-02 21:47:55Z kwm $
PORTNAME= libgweather
-PORTVERSION= 2.30.3
-PORTREVISION= 3
+PORTVERSION= 3.14.0
CATEGORIES= net gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Library to accessing online weather informations
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
-LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
+BUILD_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme
+LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libgeocode-glib.so:${PORTSDIR}/net/geocode-glib
+RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme
-CONFLICTS= libgweather-3.[0-9]*
-
-USES= gmake gettext libtool:keepla pathfix pkgconfig tar:bzip2
-USE_GNOME= gnomeprefix intlhack gconf2
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomeprefix gtk30 intlhack \
+ introspection:build
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-
-GCONF_SCHEMAS= gweather.schemas
+GLIB_SCHEMAS= org.gnome.GWeather.enums.xml \
+ org.gnome.GWeather.gschema.xml
.include <bsd.port.mk>