aboutsummaryrefslogtreecommitdiff
path: root/net/libwebsockets/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/libwebsockets/files')
-rw-r--r--net/libwebsockets/files/patch-cmake_libwebsockets-config-version.cmake.in8
-rw-r--r--net/libwebsockets/files/patch-lib_CMakeLists.txt38
2 files changed, 46 insertions, 0 deletions
diff --git a/net/libwebsockets/files/patch-cmake_libwebsockets-config-version.cmake.in b/net/libwebsockets/files/patch-cmake_libwebsockets-config-version.cmake.in
new file mode 100644
index 000000000000..9566f8f72cd6
--- /dev/null
+++ b/net/libwebsockets/files/patch-cmake_libwebsockets-config-version.cmake.in
@@ -0,0 +1,8 @@
+--- cmake/libwebsockets-config-version.cmake.in.orig 1970-01-01 00:00:00 UTC
++++ cmake/libwebsockets-config-version.cmake.in
+@@ -1,4 +1,4 @@
+-set(PACKAGE_VERSION "@CPACK_PACKAGE_VERSION@")
++set(PACKAGE_VERSION "@CPACK_PACKAGE_VERSION_MAJOR@.@CPACK_PACKAGE_VERSION_MINOR@.@CPACK_PACKAGE_VERSION_PATCH_NUMBER@")
+
+ # Check whether the requested PACKAGE_FIND_VERSION is compatible
+ if("${PACKAGE_VERSION}" VERSION_LESS "${PACKAGE_FIND_VERSION}")
diff --git a/net/libwebsockets/files/patch-lib_CMakeLists.txt b/net/libwebsockets/files/patch-lib_CMakeLists.txt
new file mode 100644
index 000000000000..7e684131fabb
--- /dev/null
+++ b/net/libwebsockets/files/patch-lib_CMakeLists.txt
@@ -0,0 +1,38 @@
+--- lib/CMakeLists.txt.orig 2023-02-14 23:28:15 UTC
++++ lib/CMakeLists.txt
+@@ -316,7 +316,7 @@ includedir=\${prefix}/include
+
+ Name: libwebsockets
+ Description: Websockets server and client library
+-Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}
++Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH_NUMBER}
+
+ Libs: -L\${libdir} -lwebsockets
+ Cflags: -I\${includedir}
+@@ -328,7 +328,7 @@ endif()
+
+
+ install(FILES "${PROJECT_BINARY_DIR}/libwebsockets.pc"
+- DESTINATION lib${LIB_SUFFIX}/pkgconfig)
++ DESTINATION libdata/pkgconfig)
+
+ file(WRITE "${PROJECT_BINARY_DIR}/libwebsockets_static.pc"
+ "prefix=\"${CMAKE_INSTALL_PREFIX}\"
+@@ -338,7 +338,7 @@ includedir=\${prefix}/include
+
+ Name: libwebsockets_static
+ Description: Websockets server and client static library
+-Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}
++Version: ${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH_NUMBER}
+
+ Libs: -L\${libdir} -l:libwebsockets${CMAKE_STATIC_LIBRARY_SUFFIX}
+ Libs.private:
+@@ -352,7 +352,7 @@ endif()
+
+
+ install(FILES "${PROJECT_BINARY_DIR}/libwebsockets_static.pc"
+- DESTINATION lib${LIB_SUFFIX}/pkgconfig)
++ DESTINATION libdata/pkgconfig)
+
+ endif(UNIX OR MINGW)
+