aboutsummaryrefslogtreecommitdiff
path: root/net/mDNSResponder/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mDNSResponder/Makefile')
-rw-r--r--net/mDNSResponder/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/net/mDNSResponder/Makefile b/net/mDNSResponder/Makefile
index 03f08663f2d0..1399c93153d3 100644
--- a/net/mDNSResponder/Makefile
+++ b/net/mDNSResponder/Makefile
@@ -1,12 +1,12 @@
-# Created by: Alfred Perlstein <alfred@FreeBSD.org>
-
PORTNAME= mDNSResponder
-PORTVERSION= 1310.140.1
-CATEGORIES= net dns
+PORTVERSION= 2200.80.16
+CATEGORIES?= net dns
MASTER_SITES= https://opensource.apple.com/tarballs/mDNSResponder/
-MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= Bonjour (zero-configuration networking) by Apple
+MAINTAINER?= sunpoet@FreeBSD.org
+COMMENT?= Bonjour (zero-configuration networking) by Apple
+WWW?= https://developer.apple.com/bonjour/ \
+ https://github.com/apple-oss-distributions/mDNSResponder
LICENSE= APACHE20 BSD3CLAUSE
LICENSE_COMB= dual
@@ -20,17 +20,16 @@ MAKE_ARGS= LDCONFIG=${TRUE} LOCALBASE=${PREFIX} MAN_PATH=${PREFIX}/share/man STR
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USE_RC_SUBR= mdnsd mdnsresponderposix
+WRKSRC= ${WRKDIR}/mDNSResponder-mDNSResponder-${PORTVERSION}
CPE_VENDOR= apple
-CPE_PRODUCT= ${PORTNAME:tl}
EXTRA_BIN= mDNSClientPosix mDNSNetMonitor mDNSProxyResponderPosix mDNSResponderPosix
EXTRA_MAN1= dns-sd.1
EXTRA_MAN8= dnsextd.8 mDNSResponderPosix.8
EXTRA_SBIN= dnsextd
-# lib/libdns_sd.so.1 sbin/mdnsd
-CONFLICTS_INSTALL= avahi-libdns openmdns
+CONFLICTS_INSTALL?= avahi-libdns openmdns # lib/libdns_sd.so.1 sbin/mdnsd
OPTIONS_DEFINE= IPV6