aboutsummaryrefslogtreecommitdiff
path: root/net/natscli/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/natscli/Makefile')
-rw-r--r--net/natscli/Makefile75
1 files changed, 39 insertions, 36 deletions
diff --git a/net/natscli/Makefile b/net/natscli/Makefile
index 4dcccdd6375e..6a8aeb36b199 100644
--- a/net/natscli/Makefile
+++ b/net/natscli/Makefile
@@ -1,11 +1,12 @@
PORTNAME= natscli
-PORTVERSION= 0.0.33
+PORTVERSION= 0.1.4
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 2
CATEGORIES= net
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Command line utility to interact with and manage NATS
+WWW= https://github.com/nats-io/natscli
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -13,49 +14,51 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= nats-io
-GH_TUPLE= AlecAivazis:survey:v2.3.4:alecaivazis_survey_v2/vendor/github.com/AlecAivazis/survey/v2 \
+GH_TUPLE= AlecAivazis:survey:v2.3.7:alecaivazis_survey_v2/vendor/github.com/AlecAivazis/survey/v2 \
HdrHistogram:hdrhistogram-go:v1.1.2:hdrhistogram_hdrhistogram_go/vendor/github.com/HdrHistogram/hdrhistogram-go \
- alecthomas:kingpin:v2.2.6:alecthomas_kingpin/vendor/gopkg.in/alecthomas/kingpin.v2 \
- alecthomas:template:fb15b899a751:alecthomas_template/vendor/github.com/alecthomas/template \
- alecthomas:units:b94a6e3cc137:alecthomas_units/vendor/github.com/alecthomas/units \
beorn7:perks:v1.0.1:beorn7_perks/vendor/github.com/beorn7/perks \
- cespare:xxhash:v2.1.2:cespare_xxhash_v2/vendor/github.com/cespare/xxhash/v2 \
- dustin:go-humanize:v1.0.0:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
- emicklei:dot:v0.16.0:emicklei_dot/vendor/github.com/emicklei/dot \
- fatih:color:v1.13.0:fatih_color/vendor/github.com/fatih/color \
+ cespare:xxhash:v2.2.0:cespare_xxhash_v2/vendor/github.com/cespare/xxhash/v2 \
+ choria-io:fisk:v0.6.2:choria_io_fisk/vendor/github.com/choria-io/fisk \
+ dustin:go-humanize:v1.0.1:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
+ emicklei:dot:v1.6.1:emicklei_dot/vendor/github.com/emicklei/dot \
+ expr-lang:expr:v1.16.1:expr_lang_expr/vendor/github.com/expr-lang/expr \
+ fatih:color:v1.16.0:fatih_color/vendor/github.com/fatih/color \
ghodss:yaml:v1.0.0:ghodss_yaml/vendor/github.com/ghodss/yaml \
go-yaml:yaml:v2.4.0:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
- golang:crypto:793ad666bf5e:golang_crypto/vendor/golang.org/x/crypto \
- golang:protobuf:v1.5.2:golang_protobuf/vendor/github.com/golang/protobuf \
- golang:sys:da31bd327af9:golang_sys/vendor/golang.org/x/sys \
- golang:term:065cf7ba2467:golang_term/vendor/golang.org/x/term \
- golang:text:v0.3.7:golang_text/vendor/golang.org/x/text \
- golang:time:f0f3c7e86c11:golang_time/vendor/golang.org/x/time \
- google:go-cmp:v0.5.8:google_go_cmp/vendor/github.com/google/go-cmp \
+ go-yaml:yaml:v3.0.1:go_yaml_yaml_1/vendor/gopkg.in/yaml.v3 \
+ golang:crypto:v0.21.0:golang_crypto/vendor/golang.org/x/crypto \
+ golang:net:v0.22.0:golang_net/vendor/golang.org/x/net \
+ golang:sys:v0.18.0:golang_sys/vendor/golang.org/x/sys \
+ golang:term:v0.18.0:golang_term/vendor/golang.org/x/term \
+ golang:text:v0.14.0:golang_text/vendor/golang.org/x/text \
+ golang:time:v0.5.0:golang_time/vendor/golang.org/x/time \
+ google:go-cmp:v0.6.0:google_go_cmp/vendor/github.com/google/go-cmp \
+ google:shlex:e7afc7fbc510:google_shlex/vendor/github.com/google/shlex \
gosuri:uilive:v0.0.4:gosuri_uilive/vendor/github.com/gosuri/uilive \
gosuri:uiprogress:v0.0.1:gosuri_uiprogress/vendor/github.com/gosuri/uiprogress \
- guptarohit:asciigraph:v0.5.5:guptarohit_asciigraph/vendor/github.com/guptarohit/asciigraph \
+ guptarohit:asciigraph:v0.5.6:guptarohit_asciigraph/vendor/github.com/guptarohit/asciigraph \
+ jedib0t:go-pretty:v6.5.4:jedib0t_go_pretty_v6/vendor/github.com/jedib0t/go-pretty/v6 \
kballard:go-shellquote:95032a82bc51:kballard_go_shellquote/vendor/github.com/kballard/go-shellquote \
- klauspost:compress:v1.15.5:klauspost_compress/vendor/github.com/klauspost/compress \
- mattn:go-colorable:v0.1.9:mattn_go_colorable/vendor/github.com/mattn/go-colorable \
- mattn:go-isatty:v0.0.14:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
- matttproud:golang_protobuf_extensions:v1.0.1:matttproud_golang_protobuf_extensions/vendor/github.com/matttproud/golang_protobuf_extensions \
- mgutz:ansi:9520e82c474b:mgutz_ansi/vendor/github.com/mgutz/ansi \
+ klauspost:compress:v1.17.7:klauspost_compress/vendor/github.com/klauspost/compress \
+ mattn:go-colorable:v0.1.13:mattn_go_colorable/vendor/github.com/mattn/go-colorable \
+ mattn:go-isatty:v0.0.20:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
+ mattn:go-runewidth:v0.0.15:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
+ mgutz:ansi:d51e80ef957d:mgutz_ansi/vendor/github.com/mgutz/ansi \
minio:highwayhash:v1.0.2:minio_highwayhash/vendor/github.com/minio/highwayhash \
- nats-io:jsm.go:v0.0.33:nats_io_jsm_go/vendor/github.com/nats-io/jsm.go \
- nats-io:jwt:442af02fd36a:nats_io_jwt_v2/vendor/github.com/nats-io/jwt \
- nats-io:nats-server:v2.8.4:nats_io_nats_server_v2/vendor/github.com/nats-io/nats-server/v2 \
- nats-io:nats.go:v1.16.0:nats_io_nats_go/vendor/github.com/nats-io/nats.go \
- nats-io:nkeys:v0.3.0:nats_io_nkeys/vendor/github.com/nats-io/nkeys \
+ nats-io:jsm.go:v0.1.1:nats_io_jsm_go/vendor/github.com/nats-io/jsm.go \
+ nats-io:jwt:v2.5.5:nats_io_jwt_v2/vendor/github.com/nats-io/jwt \
+ nats-io:nats-server:v2.10.12:nats_io_nats_server_v2/vendor/github.com/nats-io/nats-server/v2 \
+ nats-io:nats.go:v1.33.1:nats_io_nats_go/vendor/github.com/nats-io/nats.go \
+ nats-io:nkeys:v0.4.7:nats_io_nkeys/vendor/github.com/nats-io/nkeys \
nats-io:nuid:v1.0.1:nats_io_nuid/vendor/github.com/nats-io/nuid \
- prometheus:client_golang:v1.12.2:prometheus_client_golang/vendor/github.com/prometheus/client_golang \
- prometheus:client_model:v0.2.0:prometheus_client_model/vendor/github.com/prometheus/client_model \
- prometheus:common:v0.34.0:prometheus_common/vendor/github.com/prometheus/common \
- prometheus:procfs:v0.7.3:prometheus_procfs/vendor/github.com/prometheus/procfs \
- protocolbuffers:protobuf-go:v1.26.0:protocolbuffers_protobuf_go/vendor/google.golang.org/protobuf \
- santhosh-tekuri:jsonschema:v5.0.0:santhosh_tekuri_jsonschema_v5/vendor/github.com/santhosh-tekuri/jsonschema/v5 \
- tylertreat:hdrhistogram-writer:2e440612a39f:tylertreat_hdrhistogram_writer/vendor/github.com/tylertreat/hdrhistogram-writer \
- xlab:tablewriter:80b567a11ad5:xlab_tablewriter/vendor/github.com/xlab/tablewriter
+ prometheus:client_golang:v1.18.0:prometheus_client_golang/vendor/github.com/prometheus/client_golang \
+ prometheus:client_model:v0.6.0:prometheus_client_model/vendor/github.com/prometheus/client_model \
+ prometheus:common:v0.47.0:prometheus_common/vendor/github.com/prometheus/common \
+ prometheus:procfs:v0.13.0:prometheus_procfs/vendor/github.com/prometheus/procfs \
+ protocolbuffers:protobuf-go:v1.33.0:protocolbuffers_protobuf_go/vendor/google.golang.org/protobuf \
+ rivo:uniseg:v0.4.7:rivo_uniseg/vendor/github.com/rivo/uniseg \
+ santhosh-tekuri:jsonschema:v5.3.1:santhosh_tekuri_jsonschema_v5/vendor/github.com/santhosh-tekuri/jsonschema/v5 \
+ tylertreat:hdrhistogram-writer:2e440612a39f:tylertreat_hdrhistogram_writer/vendor/github.com/tylertreat/hdrhistogram-writer
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
GO_TARGET= ./nats